# CVE-2026-2835: HTTP Request Smuggling via HTTP/1.0 and Transfer-Encoding Misparsing

> Attackers can smuggle HTTP requests to bypass security controls and poison caches in Pingora proxy deployments.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:H/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Mar 2026
- **Updated:** 6 Mar 2026
- **Also known as:** GHSA-hj7x-879w-vrp7, RUSTSEC-2026-0034

## What is CVE-2026-2835?

CVE-2026-2835 is a critical vulnerability in https://github.com/cloudflare/pingora, published on 4 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An HTTP Request Smuggling vulnerability (CWE-444) has been found in Pingora's parsing of HTTP/1.0 and Transfer-Encoding requests. The issue occurs due to improperly allowing HTTP/1.0 request bodies to be close-delimited and incorrect handling of multiple Transfer-Encoding values, allowing attackers to send HTTP/1.0 requests in a way that would desync Pingora’s request framing from backend servers’.

Impact

This vulnerability primarily affects standalone Pingora deployments in front of certain backends that accept HTTP/1.0 requests. An attacker could craft a malicious payload following this request that Pingora forwards to the backend in order to:

  *  Bypass proxy-level ACL controls and WAF logic

  *  Poison caches and upstream connections, causing subsequent requests from legitimate users to receive responses intended for smuggled requests

  *  Perform cross-user attacks by hijacking sessions or smuggling requests that appear to originate from the trusted proxy IP

Cloudflare's CDN infrastructure was not affected by this vulnerability, as its ingress proxy layers forwarded HTTP/1.1 requests only, rejected ambiguous framing such as invalid Content-Length values, and forwarded a single Transfer-Encoding: chunked header for chunked requests.

Mitigation:

Pingora users should upgrade to Pingora v0.8.0 or higher that fixes this issue by correctly parsing message length headers per RFC 9112 and strictly adhering to more RFC guidelines, including that HTTP request bodies are never close-delimited.

As a workaround, users can reject certain requests with an error in the request filter logic in order to stop processing bytes on the connection and disable downstream connection reuse. The user should reject any non-HTTP/1.1 request, or a request that has invalid Content-Length, multiple Transfer-Encoding headers, or Transfer-Encoding header that is not an exact “chunked” string match.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2026-2835?

3 open source packages ship an affected version, including pingora-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pingora-core` | crates.io | All versions | 0.8.0 |
| `pingora-core` | crates.io | All versions | 0.8.0 |
| `pingora-core` | crates.io | From 0.0.0-0 | 0.8.0 |

Products: Cloudflare Pingora.

## How do I fix CVE-2026-2835?

Upgrade pingora-core to 0.8.0 or later.

## Is CVE-2026-2835 being exploited?

There is no known exploitation of CVE-2026-2835 in the wild and no public exploit code.

## Other vulnerabilities in https://github.com/cloudflare/pingora

- [CVE-2026-2833](https://insights.sbomify.com/CVE-2026-2833/): HTTP Request Smuggling via Premature Upgrade (critical 9.3)
- [CVE-2026-2836](https://insights.sbomify.com/CVE-2026-2836/): Cache poisoning via insecure-by-default cache key (high 8.4)
- [CVE-2025-4366](https://insights.sbomify.com/CVE-2025-4366/): Request Smuggling Vulnerability in Pingora (high 7.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-2835 and fix it if it is affected.

What it is: CVE-2026-2835 is a critical vulnerability in https://github.com/cloudflare/pingora, published on 4 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-2835 in the wild and no public exploit code.

Affected packages and fixed versions:
- pingora-core (crates.io): affected all versions; fixed in 0.8.0
- pingora-core (crates.io): affected all versions; fixed in 0.8.0
- pingora-core (crates.io): affected from 0.0.0-0; fixed in 0.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-2835/ (Markdown: https://insights.sbomify.com/CVE-2026-2835/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-2835
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-2835
- OSV: https://osv.dev/vulnerability/CVE-2026-2835

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-2835/
Summaries are generated and may contain mistakes; the official description above is the record.
