{"answers":{"affected":"5 open source packages ship an affected version, including multipart.","exploited":"There is no known exploitation of CVE-2026-28356 in the wild and no public exploit code.","fix":"Upgrade multipart to a fixed version for your release line: 1.2.2 or 1.3.1.","what":"CVE-2026-28356 is a high-severity denial of service vulnerability in defnull multipart, published on 12 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-28356 and fix it if it is affected.\n\nWhat it is: CVE-2026-28356 is a high-severity denial of service vulnerability in defnull multipart, published on 12 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-28356 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- multipart (PyPI): affected all versions; fixed in 1.2.2, 1.3.1\n- multipart (PyPI): affected all versions; fixed in 1.2.2\n- multipart (PyPI): affected all versions; fixed in 1.2.2\n- multipart (PyPI): affected from 1.3.0; fixed in 1.3.1\n- multipart (PyPI): affected from 1.3.0; fixed in 1.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-28356/ (Markdown: https://insights.sbomify.com/CVE-2026-28356/index.md)","id":"CVE-2026-28356","markdown":"https://insights.sbomify.com/CVE-2026-28356/index.md","name":"CVE-2026-28356","record":{"aliases":["DEBIAN-CVE-2026-28356","DSA-6161-1","GHSA-p2m9-wcp5-6qw3","PYSEC-2026-2670","ROOT-APP-PYPI-CVE-2026-28356","UBUNTU-CVE-2026-28356","openSUSE-SU-2026:10333-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python multipart parser","requires_auth":"none","summary":"Attackers can cause denial of service in web applications using the multipart library by sending crafted headers that trigger exponential backtracking in regex parsing.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"multipart is a fast multipart/form-data parser for python. Prior to 1.2.2, 1.3.1 and 1.4.0-dev, the parse_options_header() function in multipart.py uses a regular expression with an ambiguous alternation, which can cause exponential backtracking (ReDoS) when parsing maliciously crafted HTTP or multipart segment headers. This can be abused for denial of service (DoS) attacks against web applications using this library to parse request headers or multipart/form-data streams. The issue is fixed in 1.2.2, 1.3.1 and 1.4.0-dev.","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ReDoS in multipart 1.3.0 - `parse_options_header()`","id":"CVE-2026-28356","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":6,"n_references":1,"next":{"headline":"NocoDB: Stored Cross-Site Scripting via Formula Cell","id":"CVE-2026-28357"},"packages":[{"ecosystem":"PyPI","fixed":["1.2.2","1.3.1"],"introduced":["0","1.3.0"],"last_affected":[],"package":"multipart","purl":"pkg:pypi/multipart","source":"PYSEC-2026-2670"},{"ecosystem":"PyPI","fixed":["1.2.2"],"introduced":["0"],"last_affected":[],"package":"multipart","purl":null,"source":"GHSA-p2m9-wcp5-6qw3"},{"ecosystem":"PyPI","fixed":["1.2.2"],"introduced":["0"],"last_affected":[],"package":"multipart","purl":"pkg:pypi/multipart","source":"GHSA-p2m9-wcp5-6qw3"},{"ecosystem":"PyPI","fixed":["1.3.1"],"introduced":["1.3.0"],"last_affected":[],"package":"multipart","purl":null,"source":"GHSA-p2m9-wcp5-6qw3"},{"ecosystem":"PyPI","fixed":["1.3.1"],"introduced":["1.3.0"],"last_affected":[],"package":"multipart","purl":"pkg:pypi/multipart","source":"GHSA-p2m9-wcp5-6qw3"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.3.1-1.1"],"introduced":["0"],"last_affected":[],"package":"python-multipart","purl":"pkg:rpm/opensuse/python-multipart\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10333-1"}],"prev":{"headline":"\"PWA\" Canarytoken Vulnerable to Stored Self Cross-Site Scripting","id":"CVE-2026-28355"},"products":["multipart"],"published":"2026-03-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-24","vendors":["defnull"]},"summary":"Attackers can cause denial of service in web applications using the multipart library by sending crafted headers that trigger exponential backtracking in regex parsing.","url":"https://insights.sbomify.com/CVE-2026-28356/"}