# CVE-2026-28356: ReDoS in multipart 1.3.0 - `parse_options_header()`

> Attackers can cause denial of service in web applications using the multipart library by sending crafted headers that trigger exponential backtracking in regex parsing.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Mar 2026
- **Updated:** 24 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-28356, DSA-6161-1, GHSA-p2m9-wcp5-6qw3, PYSEC-2026-2670, ROOT-APP-PYPI-CVE-2026-28356, UBUNTU-CVE-2026-28356, openSUSE-SU-2026:10333-1

## What is CVE-2026-28356?

CVE-2026-28356 is a high-severity denial of service vulnerability in defnull multipart, published on 12 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

multipart is a fast multipart/form-data parser for python. Prior to 1.2.2, 1.3.1 and 1.4.0-dev, the parse_options_header() function in multipart.py uses a regular expression with an ambiguous alternation, which can cause exponential backtracking (ReDoS) when parsing maliciously crafted HTTP or multipart segment headers. This can be abused for denial of service (DoS) attacks against web applications using this library to parse request headers or multipart/form-data streams. The issue is fixed in 1.2.2, 1.3.1 and 1.4.0-dev.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2026-28356?

5 open source packages ship an affected version, including multipart.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `multipart` | PyPI | All versions | 1.2.2, 1.3.1 |
| `multipart` | PyPI | All versions | 1.2.2 |
| `multipart` | PyPI | All versions | 1.2.2 |
| `multipart` | PyPI | From 1.3.0 | 1.3.1 |
| `multipart` | PyPI | From 1.3.0 | 1.3.1 |
| `python-multipart` | openSUSE:Tumbleweed | All versions | 1.3.1-1.1 |

## How do I fix CVE-2026-28356?

Upgrade multipart to a fixed version for your release line: 1.2.2 or 1.3.1.

## Is CVE-2026-28356 being exploited?

There is no known exploitation of CVE-2026-28356 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-28356 and fix it if it is affected.

What it is: CVE-2026-28356 is a high-severity denial of service vulnerability in defnull multipart, published on 12 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-28356 in the wild and no public exploit code.

Affected packages and fixed versions:
- multipart (PyPI): affected all versions; fixed in 1.2.2, 1.3.1
- multipart (PyPI): affected all versions; fixed in 1.2.2
- multipart (PyPI): affected all versions; fixed in 1.2.2
- multipart (PyPI): affected from 1.3.0; fixed in 1.3.1
- multipart (PyPI): affected from 1.3.0; fixed in 1.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-28356/ (Markdown: https://insights.sbomify.com/CVE-2026-28356/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-28356
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-28356
- OSV: https://osv.dev/vulnerability/CVE-2026-28356

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-28356/
Summaries are generated and may contain mistakes; the official description above is the record.
