# CVE-2026-28359: NocoDB: Stored Cross-Site Scripting via Rich Text Field

> An authenticated Editor can inject arbitrary HTML into Rich Text cells via the API, enabling stored XSS attacks against other users.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Mar 2026
- **Updated:** 3 Mar 2026
- **Also known as:** GHSA-qxwq-q265-hc44

## What is CVE-2026-28359?

CVE-2026-28359 is a medium-severity cross-site scripting vulnerability in nocodb, published on 2 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

NocoDB is software for building databases as spreadsheets. Prior to version 0.301.3, an authenticated user with Editor role can inject arbitrary HTML into Rich Text cells by bypassing the TipTap editor and sending raw HTML via the API. This issue has been patched in version 0.301.3.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-28359?

2 open source packages ship an affected version, including nocodb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nocodb` | npm | All versions | 0.301.3 |
| `nocodb` | npm | All versions | 0.301.3 |

Products: Nocodb Nocodb.

## How do I fix CVE-2026-28359?

Upgrade nocodb to 0.301.3 or later.

## Is CVE-2026-28359 being exploited?

There is no known exploitation of CVE-2026-28359 in the wild and no public exploit code.

## Other vulnerabilities in nocodb

- [CVE-2022-2339](https://insights.sbomify.com/CVE-2022-2339/): Server-Side Request Forgery (SSRF) in nocodb/nocodb (critical 9.1)
- [CVE-2022-2062](https://insights.sbomify.com/CVE-2022-2062/): Generation of Error Message Containing Sensitive Information in nocodb/nocodb (critical 9.1)
- [CVE-2022-2064](https://insights.sbomify.com/CVE-2022-2064/): Insufficient Session Expiration in nocodb/nocodb (critical 9.1)
- [CVE-2022-2063](https://insights.sbomify.com/CVE-2022-2063/): Improper Privilege Management in nocodb/nocodb (critical 9.0)
- [CVE-2022-2022](https://insights.sbomify.com/CVE-2022-2022/): Cross-site Scripting (XSS) - Stored in nocodb/nocodb (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-28359 and fix it if it is affected.

What it is: CVE-2026-28359 is a medium-severity cross-site scripting vulnerability in nocodb, published on 2 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-28359 in the wild and no public exploit code.

Affected packages and fixed versions:
- nocodb (npm): affected all versions; fixed in 0.301.3
- nocodb (npm): affected all versions; fixed in 0.301.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-28359/ (Markdown: https://insights.sbomify.com/CVE-2026-28359/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-28359
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-28359
- OSV: https://osv.dev/vulnerability/CVE-2026-28359

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-28359/
Summaries are generated and may contain mistakes; the official description above is the record.
