# CVE-2026-28370: OpenStack Vitrage: Unauthorized Access to the Host can Lead to Eval Injection

> An authenticated user can trigger code execution on the Vitrage service host via the query parser, leading to potential host compromise.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Feb 2026
- **Updated:** 5 Mar 2026
- **Also known as:** DEBIAN-CVE-2026-28370, GHSA-8xwf-cr4r-856r, PYSEC-2026-564, UBUNTU-CVE-2026-28370

## What is CVE-2026-28370?

CVE-2026-28370 is a critical code injection vulnerability in OpenStack Vitrage, published on 27 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

In the query parser in OpenStack Vitrage before 12.0.1, 13.0.0, 14.0.0, and 15.0.0, a user allowed to access the Vitrage API may trigger code execution on the Vitrage service host as the user the Vitrage service runs under. This may result in unauthorized access to the host and further compromise of the Vitrage service. All deployments exposing the Vitrage API are affected. This occurs in _create_query_function in vitrage/graph/query.py.

Weakness: CWE-95 (Improper Neutralization of Directives in Dynamically Evaluated Code)

## Which versions are affected by CVE-2026-28370?

9 open source packages ship an affected version, including vitrage. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vitrage` | PyPI | All versions | 12.0.1, 13.0.1, 14.0.1, 15.0.1 |
| `vitrage` | PyPI | All versions | 12.0.1 |
| `vitrage` | PyPI | All versions | 12.0.1 |
| `vitrage` | PyPI | From 13.0.0.0rc1 | 13.0.1 |
| `vitrage` | PyPI | From 13.0.0.0rc1 | 13.0.1 |
| `vitrage` | PyPI | From 14.0.0.0rc1 | 14.0.1 |
| `vitrage` | PyPI | From 14.0.0.0rc1 | 14.0.1 |
| `vitrage` | PyPI | From 15.0.0.0rc1 | 15.0.1 |
| `vitrage` | PyPI | From 15.0.0.0rc1 | 15.0.1 |

Products: Openstack Vitrage.

## How do I fix CVE-2026-28370?

Upgrade vitrage to a fixed version for your release line: 12.0.1, 13.0.1, 14.0.1 or 15.0.1.

## Is CVE-2026-28370 being exploited?

There is no known exploitation of CVE-2026-28370 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-28370 and fix it if it is affected.

What it is: CVE-2026-28370 is a critical code injection vulnerability in OpenStack Vitrage, published on 27 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-28370 in the wild and no public exploit code.

Affected packages and fixed versions:
- vitrage (PyPI): affected all versions; fixed in 12.0.1, 13.0.1, 14.0.1, 15.0.1
- vitrage (PyPI): affected all versions; fixed in 12.0.1
- vitrage (PyPI): affected all versions; fixed in 12.0.1
- vitrage (PyPI): affected from 13.0.0.0rc1; fixed in 13.0.1
- vitrage (PyPI): affected from 13.0.0.0rc1; fixed in 13.0.1
- vitrage (PyPI): affected from 14.0.0.0rc1; fixed in 14.0.1
- vitrage (PyPI): affected from 14.0.0.0rc1; fixed in 14.0.1
- vitrage (PyPI): affected from 15.0.0.0rc1; fixed in 15.0.1
- vitrage (PyPI): affected from 15.0.0.0rc1; fixed in 15.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-28370/ (Markdown: https://insights.sbomify.com/CVE-2026-28370/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-28370
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-28370
- OSV: https://osv.dev/vulnerability/CVE-2026-28370

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-28370/
Summaries are generated and may contain mistakes; the official description above is the record.
