CVE-2026-2839 The Advanced Custom Fields: Extended plugin for WordPress is vulnerable to unauthorized access of data and triggering of server-side actions

Medium 5.3 Published Updated
Exploited in the wild
Not known
Fix
None listed

What is CVE-2026-2839?

CVE-2026-2839 is a medium-severity vulnerability in hwk-fr Advanced Custom Fields: Extended, published on 28 Oct 2026.

Official description

The Advanced Custom Fields: Extended plugin for WordPress is vulnerable to unauthorized access of data and triggering of server-side actions in all versions up to, and including, 0.9.2.7. This is due to multiple AJAX handlers registered for unauthenticated users (`wp_ajax_nopriv_*`) that fail to implement proper `current_user_can()` authorization checks. While these handlers use ACF's `acf_verify_ajax()` function to validate cryptographic nonces, the `acf_nonce` values are generated for guest users and publicly exposed in the page source of any frontend page utilizing an ACF form. This makes it possible for unauthenticated attackers to extract the guest nonce and bypass WordPress visibility permissions, leading to the unauthorized disclosure of post titles and internal Flexible Content layout structures. The vulnerability was partially patched in version 0.9.2.4.

Weakness: CWE-862

Which versions are affected by CVE-2026-2839?

How do I fix CVE-2026-2839?

No fix has been published for CVE-2026-2839 yet. Limit exposure of the affected software until one is available.

Is CVE-2026-2839 being exploited?

There is no known exploitation of CVE-2026-2839 in the wild and no public exploit code.

Sources

Also known as GHSA-6687-wfp7-4mp6.

Is CVE-2026-2839 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free