CVE-2026-28393 OpenClaw 2.0.0-beta3 < 2026.2.14 - Arbitrary JavaScript Module Loading via Hook Transform Path Traversal

High 8.3 Published Updated

Attackers with configuration write access can execute arbitrary JavaScript via path traversal in hook transforms, compromising the gateway process.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2026-28393?

CVE-2026-28393 is a high-severity path traversal vulnerability in Openclaw Openclaw, published on 5 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

OpenClaw versions 2.0.0-beta3 prior to 2026.2.14 contain a path traversal vulnerability in hook transform module loading that allows arbitrary JavaScript execution. The hooks.mappings[].transform.module parameter accepts absolute paths and traversal sequences, enabling attackers with configuration write access to load and execute malicious modules with gateway process privileges.

Weakness: CWE-22

Which versions are affected by CVE-2026-28393?

2 open source packages ship an affected version, including openclaw. It affects 1 product.

PackageAffectedFixed in
openclaw npmFrom 2.0.0-beta32026.2.14
openclaw npmFrom 2.0.0-beta32026.2.14

Products include Openclaw Openclaw.

How do I fix CVE-2026-28393?

Upgrade openclaw to 2026.2.14 or later.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2026-28393 being exploited?

There is no known exploitation of CVE-2026-28393 in the wild and no public exploit code.

All Openclaw Openclaw vulnerabilities

Sources

Also known as GHSA-7xhj-55q9-pc3m.

Is CVE-2026-28393 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free