# CVE-2026-28407: malcontent's nested archive extraction failure can drop content from scan inputs

> Attackers can evade detection by hiding malicious content in nested archives that fail to extract, as the tool previously discarded them instead of scanning.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Feb 2026
- **Updated:** 2 Mar 2026
- **Also known as:** GHSA-945p-3jhm-6rcp, GO-2026-4577

## What is CVE-2026-28407?

CVE-2026-28407 is a medium-severity vulnerability in chainguard-dev malcontent, published on 27 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

malcontent is software for discovering supply-chain compromises through context, differential analysis, and YARA. Prior to version 1.21.0, malcontent would remove nested archives which failed to extract which could potentially leave malicious content. A better approach is to preserve these archives so that malcontent can attempt a best-effort scan of the archive bytes. Version 1.21.0 fixes the issue.

Weakness: CWE-703 (Improper Check or Handling of Exceptional Conditions)

## Which versions are affected by CVE-2026-28407?

3 open source packages ship an affected version, including github.com/chainguard-dev/malcontent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/chainguard-dev/malcontent` | Go | All versions | 1.21.0 |
| `github.com/chainguard-dev/malcontent` | Go | All versions | 1.21.0 |
| `github.com/chainguard-dev/malcontent` | Go | All versions | 1.21.0 |

Products: Chainguard Malcontent.

## How do I fix CVE-2026-28407?

Upgrade github.com/chainguard-dev/malcontent to 1.21.0 or later.

## Is CVE-2026-28407 being exploited?

There is no known exploitation of CVE-2026-28407 in the wild and no public exploit code.

## Other vulnerabilities in chainguard-dev malcontent

- [CVE-2026-24845](https://insights.sbomify.com/CVE-2026-24845/): malcontent's OCI image scanning could expose registry credentials (medium 6.5)
- [CVE-2026-24846](https://insights.sbomify.com/CVE-2026-24846/): malcontent's archive extraction could write outside extraction directory (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-28407 and fix it if it is affected.

What it is: CVE-2026-28407 is a medium-severity vulnerability in chainguard-dev malcontent, published on 27 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-28407 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/chainguard-dev/malcontent (Go): affected all versions; fixed in 1.21.0
- github.com/chainguard-dev/malcontent (Go): affected all versions; fixed in 1.21.0
- github.com/chainguard-dev/malcontent (Go): affected all versions; fixed in 1.21.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-28407/ (Markdown: https://insights.sbomify.com/CVE-2026-28407/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-28407
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-28407
- OSV: https://osv.dev/vulnerability/CVE-2026-28407

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-28407/
Summaries are generated and may contain mistakes; the official description above is the record.
