# CVE-2026-28415: Gradio has Open Redirect in OAuth Flow

> Attackers can redirect users to malicious sites via unvalidated URL parameters in Gradio's OAuth flow when OAuth is enabled.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Feb 2026
- **Updated:** 2 Mar 2026
- **Also known as:** GHSA-pfjf-5gxr-995x, PYSEC-2026-65

## What is CVE-2026-28415?

CVE-2026-28415 is a medium-severity vulnerability in Gradio Project Gradio, published on 27 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Gradio is an open-source Python package designed for quick prototyping. Prior to version 6.6.0, the _redirect_to_target() function in Gradio's OAuth flow accepts an unvalidated _target_url query parameter, allowing redirection to arbitrary external URLs. This affects the /logout and /login/callback endpoints on Gradio apps with OAuth enabled (i.e. apps running on Hugging Face Spaces with gr.LoginButton). Starting in version 6.6.0, the _target_url parameter is sanitized to only use the path, query, and fragment, stripping any scheme or host.

Weakness: CWE-601 (URL Redirection to Untrusted Site), CWE-330 (Use of Insufficiently Random Values), CWE-284 (Improper Access Control), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-28415?

3 open source packages ship an affected version, including gradio. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gradio` | PyPI | All versions | 6.6.0 |
| `gradio` | PyPI | All versions | 6.6.0 |
| `gradio` | PyPI | All versions | 6.6.0 |

Products: Gradio Project Gradio.

## How do I fix CVE-2026-28415?

Upgrade gradio to 6.6.0 or later.

## Is CVE-2026-28415 being exploited?

There is no known exploitation of CVE-2026-28415 in the wild and no public exploit code.

## Other vulnerabilities in Gradio Project Gradio

- [CVE-2024-39236](https://insights.sbomify.com/CVE-2024-39236/): Withdrawn Advisory: Gradio was discovered to contain a code injection vulnerability via the component /gradio/component_meta.py (critical 9.8)
- [CVE-2023-6572](https://insights.sbomify.com/CVE-2023-6572/): Command Injection in gradio-app/gradio (critical 9.6)
- [CVE-2022-24770](https://insights.sbomify.com/CVE-2022-24770/): Improper Neutralization of Formula Elements in a CSV File in Gradio Flagging (high 8.8)
- [CVE-2026-49119](https://insights.sbomify.com/CVE-2026-49119/): Gradio < 6.16.0 Path Traversal via FileExplorer.preprocess() (high 8.7)
- [CVE-2025-23042](https://insights.sbomify.com/CVE-2025-23042/): Gradio Blocked Path ACL Bypass Vulnerability (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-28415 and fix it if it is affected.

What it is: CVE-2026-28415 is a medium-severity vulnerability in Gradio Project Gradio, published on 27 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-28415 in the wild and no public exploit code.

Affected packages and fixed versions:
- gradio (PyPI): affected all versions; fixed in 6.6.0
- gradio (PyPI): affected all versions; fixed in 6.6.0
- gradio (PyPI): affected all versions; fixed in 6.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-28415/ (Markdown: https://insights.sbomify.com/CVE-2026-28415/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-28415
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-28415
- OSV: https://osv.dev/vulnerability/CVE-2026-28415

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-28415/
Summaries are generated and may contain mistakes; the official description above is the record.
