{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-28417 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-28417 is a medium-severity command injection vulnerability in Vim Vim, published on 27 Feb 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-28417 and fix it if it is affected.\n\nWhat it is: CVE-2026-28417 is a medium-severity command injection vulnerability in Vim Vim, published on 27 Feb 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-28417 in the wild and no public exploit code.\n\nAffected product: Vim Vim. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-28417/ (Markdown: https://insights.sbomify.com/CVE-2026-28417/index.md)","id":"CVE-2026-28417","markdown":"https://insights.sbomify.com/CVE-2026-28417/index.md","name":"CVE-2026-28417","record":{"aliases":["ALPINE-CVE-2026-28417","AZL-78497","BELL-CVE-2026-28417","DEBIAN-CVE-2026-28417","ECHO-180e-0061-390d","GHSA-m3xh-9434-g336","ROOT-OS-DEBIAN-11-CVE-2026-28417","ROOT-OS-DEBIAN-12-CVE-2026-28417","SUSE-SU-2026:20732-1","UBUNTU-CVE-2026-28417","USN-8101-1"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Vim text editor","requires_auth":"none","summary":"An attacker can execute arbitrary shell commands by tricking a user into opening a crafted URL in Vim's netrw plugin.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"vim","vendor":"vim"}],"cvss":{"score":4.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"},{"id":"CWE-86","name":"Improper Neutralization of Invalid Characters in Identifiers in Web Pages"}],"description":"Vim is an open source, command line text editor. Prior to version 9.2.0073, an OS command injection vulnerability exists in the `netrw` standard plugin bundled with Vim. By inducing a user to open a crafted URL (e.g., using the `scp://` protocol handler), an attacker can execute arbitrary shell commands with the privileges of the Vim process. Version 9.2.0073 fixes the issue.","ecosystems":["SUSE:Linux Micro 6.0"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Vim has OS Command Injection in netrw","id":"CVE-2026-28417","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"vim:vim","products":["vim:vim"],"type":"command_injection","year":"2026"},"n_packages":1,"n_references":3,"next":{"headline":"Vim has Heap-based Buffer Overflow in Emacs tags parsing","id":"CVE-2026-28418"},"packages":[{"ecosystem":"SUSE:Linux Micro 6.0","fixed":["9.2.0110-1.1"],"introduced":["0"],"last_affected":[],"package":"vim","purl":"pkg:rpm/suse/vim\u0026distro=SUSE%20Linux%20Micro%206.0","source":"SUSE-SU-2026:20732-1"}],"prev":{"headline":"Gradio has SSRF via Malicious `proxy_url` Injection in `gr.load()` Config Processing","id":"CVE-2026-28416"},"products":["vim"],"published":"2026-02-27","related":[{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2020-20703","kev_date_added":null,"published":"2023-06-20"},{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2017-6349","kev_date_added":null,"published":"2017-02-27"},{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2017-6350","kev_date_added":null,"published":"2017-02-27"},{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2017-5953","kev_date_added":null,"published":"2017-02-10"},{"cvss_score":9.3,"headline":"Command injection in n/a","id":"CVE-2008-3075","kev_date_added":null,"published":"2009-02-21"},{"cvss_score":9.3,"headline":"Command injection in n/a","id":"CVE-2008-3076","kev_date_added":null,"published":"2009-02-21"},{"cvss_score":9.3,"headline":"Command injection in n/a","id":"CVE-2008-6235","kev_date_added":null,"published":"2009-02-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-28","vendors":["vim"]},"summary":"An attacker can execute arbitrary shell commands by tricking a user into opening a crafted URL in Vim's netrw plugin.","url":"https://insights.sbomify.com/CVE-2026-28417/"}