CVE-2026-28425 Statamic vulnerable to remote code execution via Antlers-enabled control panel inputs
Authenticated users with specific permissions can achieve remote code execution via Antlers-enabled inputs in Statamic CMS.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-28425?
CVE-2026-28425 is a high-severity code injection vulnerability in statamic cms, published on 27 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Statmatic is a Laravel and Git powered content management system (CMS). Prior to versions 5.73.16 and 6.7.2, an authenticated control panel user with access to Antlers-enabled inputs may be able to achieve remote code execution in the application context. That can lead to full compromise of the application, including access to sensitive configuration, modification or exfiltration of data, and potential impact on availability. Exploitation is only possible where Antlers runs on user-controlled content—for example, content fields with Antlers explicitly enabled (requiring permission to configure fields and to edit entries), built-in config that supports Antlers such as Forms email notification settings (requiring configuration permission), or third-party addons that add Antlers-enabled fields to entries (for example, the SEO Pro addon). In each case the attacker must have the relevant control panel permissions. This has been fixed in 5.73.16 and 6.7.2. Users of addons that depend on Statamic should ensure that after updating they are running a patched Statamic version.
Weakness: CWE-94
Which versions are affected by CVE-2026-28425?
4 open source packages ship an affected version, including statamic/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
statamic/cms Packagist | All versions | 5.73.16 |
statamic/cms Packagist | All versions | 5.73.16 |
statamic/cms Packagist | From 6.0.0-alpha.1 | 6.7.2 |
statamic/cms Packagist | From 6.0.0-alpha.1 | 6.7.2 |
Products include Statamic Statamic.
How do I fix CVE-2026-28425?
Upgrade statamic/cms to a fixed version for your release line: 5.73.16 or 6.7.2.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-28425 being exploited?
There is no known exploitation of CVE-2026-28425 in the wild and no public exploit code.
Other vulnerabilities in statamic cms
- CVE-2021-45364 Code injection in n/a
- CVE-2026-27593 Statamic is vulnerable to account takeover via password reset link injection
- CVE-2026-27939 Statamic allows Authenticated Control Panel users to escalate privileges via elevated session bypass
- CVE-2023-48217 Remote code execution via form uploads in statamic/cms
- CVE-2017-11422 Statamic framework Incorrect Permission Assignment
Sources
Also known as GHSA-cpv7-q2wx-m8rw.