# CVE-2026-28425: Statamic vulnerable to remote code execution via Antlers-enabled control panel inputs

> Authenticated users with specific permissions can achieve remote code execution via Antlers-enabled inputs in Statamic CMS.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Feb 2026
- **Updated:** 25 Mar 2026
- **Also known as:** GHSA-cpv7-q2wx-m8rw

## What is CVE-2026-28425?

CVE-2026-28425 is a high-severity code injection vulnerability in statamic cms, published on 27 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Statmatic is a Laravel and Git powered content management system (CMS). Prior to versions 5.73.16 and 6.7.2, an authenticated control panel user with access to Antlers-enabled inputs may be able to achieve remote code execution in the application context. That can lead to full compromise of the application, including access to sensitive configuration, modification or exfiltration of data, and potential impact on availability. Exploitation is only possible where Antlers runs on user-controlled content—for example, content fields with Antlers explicitly enabled (requiring permission to configure fields and to edit entries), built-in config that supports Antlers such as Forms email notification settings (requiring configuration permission), or third-party addons that add Antlers-enabled fields to entries (for example, the SEO Pro addon). In each case the attacker must have the relevant control panel permissions. This has been fixed in 5.73.16 and 6.7.2. Users of addons that depend on Statamic should ensure that after updating they are running a patched Statamic version.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-28425?

4 open source packages ship an affected version, including statamic/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `statamic/cms` | Packagist | All versions | 5.73.16 |
| `statamic/cms` | Packagist | All versions | 5.73.16 |
| `statamic/cms` | Packagist | From 6.0.0-alpha.1 | 6.7.2 |
| `statamic/cms` | Packagist | From 6.0.0-alpha.1 | 6.7.2 |

Products: Statamic Statamic.

## How do I fix CVE-2026-28425?

Upgrade statamic/cms to a fixed version for your release line: 5.73.16 or 6.7.2.

## Is CVE-2026-28425 being exploited?

There is no known exploitation of CVE-2026-28425 in the wild and no public exploit code.

## Other vulnerabilities in statamic cms

- [CVE-2021-45364](https://insights.sbomify.com/CVE-2021-45364/): Code injection in n/a (critical 9.8)
- [CVE-2026-27593](https://insights.sbomify.com/CVE-2026-27593/): Statamic is vulnerable to account takeover via password reset link injection (critical 9.3)
- [CVE-2026-27939](https://insights.sbomify.com/CVE-2026-27939/): Statamic allows Authenticated Control Panel users to escalate privileges via elevated session bypass (high 8.8)
- [CVE-2023-48217](https://insights.sbomify.com/CVE-2023-48217/): Remote code execution via form uploads in statamic/cms (high 8.8)
- [CVE-2017-11422](https://insights.sbomify.com/CVE-2017-11422/): Statamic framework Incorrect Permission Assignment (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-28425 and fix it if it is affected.

What it is: CVE-2026-28425 is a high-severity code injection vulnerability in statamic cms, published on 27 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-28425 in the wild and no public exploit code.

Affected packages and fixed versions:
- statamic/cms (Packagist): affected all versions; fixed in 5.73.16
- statamic/cms (Packagist): affected all versions; fixed in 5.73.16
- statamic/cms (Packagist): affected from 6.0.0-alpha.1; fixed in 6.7.2
- statamic/cms (Packagist): affected from 6.0.0-alpha.1; fixed in 6.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-28425/ (Markdown: https://insights.sbomify.com/CVE-2026-28425/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-28425
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-28425
- OSV: https://osv.dev/vulnerability/CVE-2026-28425

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-28425/
Summaries are generated and may contain mistakes; the official description above is the record.
