CVE-2026-28426 Statamic vulnerable to privilege escalation via stored cross-site scripting

High 8.7 Published Updated

Authenticated users can inject malicious JavaScript via SVG components, leading to privilege escalation when viewed by higher-privileged users.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-28426?

CVE-2026-28426 is a high-severity cross-site scripting vulnerability in statamic cms, published on 27 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Statmatic is a Laravel and Git powered content management system (CMS). Prior to versions 5.73.11 and 6.4.0, stored XSS vulnerability in svg and icon related components allow authenticated users with appropriate permissions to inject malicious JavaScript that executes when viewed by higher-privileged users. This has been fixed in 5.73.11 and 6.4.0.

Weakness: CWE-79

Which versions are affected by CVE-2026-28426?

4 open source packages ship an affected version, including statamic/cms. It affects 1 product.

PackageAffectedFixed in
statamic/cms PackagistAll versions5.73.11
statamic/cms PackagistAll versions5.73.11
statamic/cms PackagistFrom 6.0.0-alpha.16.4.0
statamic/cms PackagistFrom 6.0.0-alpha.16.4.0

Products include Statamic Statamic.

How do I fix CVE-2026-28426?

Upgrade statamic/cms to a fixed version for your release line: 5.73.11 or 6.4.0.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-28426 being exploited?

There is no known exploitation of CVE-2026-28426 in the wild and no public exploit code.

Sources

Also known as GHSA-5vrj-wf7v-5wr7.

Is CVE-2026-28426 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free