# CVE-2026-28436: Frappe: Stored XSS in avatar_macro.html

> An attacker can inject malicious scripts via crafted image URLs in avatars, leading to stored XSS when displayed to other users.

- **Severity:** Low 1.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 5 Mar 2026
- **Updated:** 6 Mar 2026
- **Also known as:** GHSA-vm63-r48g-7wqh

## What is CVE-2026-28436?

CVE-2026-28436 is a low-severity cross-site scripting vulnerability in frappe, published on 5 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Frappe is a full-stack web application framework. Prior to versions 16.11.0 and 15.102.0, an attacker can set a crafted image URL that results in XSS when the avatar is displayed, and it can be triggered for other users via website page comments. This issue has been patched in versions 16.11.0 and 15.102.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-28436?

It affects 1 product.


Products: Frappe Frappe.

## How do I fix CVE-2026-28436?

No fix has been published for CVE-2026-28436 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-28436 being exploited?

There is no known exploitation of CVE-2026-28436 in the wild and no public exploit code.

## Other vulnerabilities in frappe

- [CVE-2019-14965](https://insights.sbomify.com/CVE-2019-14965/): Code injection in n/a (critical 9.8)
- [CVE-2026-35614](https://insights.sbomify.com/CVE-2026-35614/): Frappe has a SQL injection in bulk_update (critical 9.3)
- [CVE-2026-31877](https://insights.sbomify.com/CVE-2026-31877/): Frappe SQL Injection due to improper field sanitization (critical 9.3)
- [CVE-2025-68929](https://insights.sbomify.com/CVE-2025-68929/): Frappe may be vulnerable remote code execution due to server-side template injection (critical 9.1)
- [CVE-2019-14966](https://insights.sbomify.com/CVE-2019-14966/): SQL injection in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-28436 and fix it if it is affected.

What it is: CVE-2026-28436 is a low-severity cross-site scripting vulnerability in frappe, published on 5 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-28436 in the wild and no public exploit code.

Affected product: frappe. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-28436/ (Markdown: https://insights.sbomify.com/CVE-2026-28436/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-28436
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-28436
- OSV: https://osv.dev/vulnerability/CVE-2026-28436

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-28436/
Summaries are generated and may contain mistakes; the official description above is the record.
