# CVE-2026-28438: CocoIndex Doris target connector didn't verify table name when constructing ALTER TABLE statements

> Attackers can execute arbitrary SQL commands via untrusted table names in the Doris connector, potentially modifying data or executing code.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Mar 2026
- **Updated:** 6 Mar 2026
- **Also known as:** GHSA-59g6-v3vg-f7wc, PYSEC-2026-2133

## What is CVE-2026-28438?

CVE-2026-28438 is a medium-severity SQL injection vulnerability in cocoindex-io cocoindex, published on 6 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CocoIndex is a data transformation framework for AI. Prior to version 0.3.34, the Doris target connector didn't verify the configured table name before creating some SQL statements (ALTER TABLE). So, in the application code, if the table name is provided by an untrusted upstream, it expose vulnerability to SQL injection when target schema change. This issue has been patched in version 0.3.34.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-28438?

3 open source packages ship an affected version, including cocoindex. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cocoindex` | PyPI | All versions | 0.3.34 |
| `cocoindex` | PyPI | All versions | 0.3.34 |
| `cocoindex` | PyPI | All versions | 0.3.34 |

Products: Cocoindex Cocoindex.

## How do I fix CVE-2026-28438?

Upgrade cocoindex to 0.3.34 or later.

## Is CVE-2026-28438 being exploited?

There is no known exploitation of CVE-2026-28438 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-28438 and fix it if it is affected.

What it is: CVE-2026-28438 is a medium-severity SQL injection vulnerability in cocoindex-io cocoindex, published on 6 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-28438 in the wild and no public exploit code.

Affected packages and fixed versions:
- cocoindex (PyPI): affected all versions; fixed in 0.3.34
- cocoindex (PyPI): affected all versions; fixed in 0.3.34
- cocoindex (PyPI): affected all versions; fixed in 0.3.34

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-28438/ (Markdown: https://insights.sbomify.com/CVE-2026-28438/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-28438
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-28438
- OSV: https://osv.dev/vulnerability/CVE-2026-28438

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-28438/
Summaries are generated and may contain mistakes; the official description above is the record.
