CVE-2026-28447 OpenClaw 2026.1.29-beta.1 < 2026.2.1 - Path Traversal in Plugin Installation via Package Name

High 7.0 Published Updated

Attackers can write files outside the intended directory via malicious plugin names during installation, requiring users to upgrade OpenClaw.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-28447?

CVE-2026-28447 is a high-severity path traversal vulnerability in Openclaw Openclaw, published on 5 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

OpenClaw versions 2026.1.29-beta.1 prior to 2026.2.1 contain a path traversal vulnerability in plugin installation that allows malicious plugin package names to escape the extensions directory. Attackers can craft scoped package names containing path traversal sequences like .. to write files outside the intended installation directory when victims run the plugins install command.

Weakness: CWE-22

Which versions are affected by CVE-2026-28447?

2 open source packages ship an affected version, including openclaw. It affects 1 product.

PackageAffectedFixed in
openclaw npmFrom 2026.1.202026.2.1
openclaw npmFrom 2026.1.202026.2.1

Products include Openclaw Openclaw.

How do I fix CVE-2026-28447?

Upgrade openclaw to 2026.2.1 or later.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2026-28447 being exploited?

There is no known exploitation of CVE-2026-28447 in the wild and no public exploit code.

All Openclaw Openclaw vulnerabilities

Sources

Also known as GHSA-qrq5-wjgg-rvqw.

Is CVE-2026-28447 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free