# CVE-2026-28452: OpenClaw < 2026.2.14 - Denial of Service via Unguarded Archive Extraction in extractArchive

> Attackers can cause resource exhaustion and service unavailability in OpenClaw by submitting malicious high-expansion archives during install or update operations.

- **Severity:** Medium 6.7 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Mar 2026
- **Updated:** 9 Mar 2026
- **Also known as:** GHSA-h89v-j3x9-8wqj

## What is CVE-2026-28452?

CVE-2026-28452 is a medium-severity denial of service vulnerability in Openclaw Openclaw, published on 5 Mar 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

OpenClaw versions prior to 2026.2.14 contain a denial of service vulnerability in the extractArchive function within src/infra/archive.ts that allows attackers to consume excessive CPU, memory, and disk resources through high-expansion ZIP and TAR archives. Remote attackers can trigger resource exhaustion by providing maliciously crafted archive files during install or update operations, causing service degradation or system unavailability.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-28452?

4 open source packages ship an affected version, including openclaw and clawdbot. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openclaw` | npm | All versions | 2026.2.14 |
| `openclaw` | npm | All versions | 2026.2.14 |
| `clawdbot` | npm | All versions to 2026.1.24-3 | None |
| `clawdbot` | npm | All versions to 2026.1.24-3 | None |

Products: Openclaw Openclaw.

## How do I fix CVE-2026-28452?

Upgrade openclaw to 2026.2.14 or later.

## Is CVE-2026-28452 being exploited?

There is no known exploitation of CVE-2026-28452 in the wild and no public exploit code.

## Other vulnerabilities in Openclaw Openclaw

- [CVE-2026-28363](https://insights.sbomify.com/CVE-2026-28363/): Security feature bypass in OpenClaw (critical 9.9)
- [CVE-2026-30741](https://insights.sbomify.com/CVE-2026-30741/): Code injection in n/a (critical 9.8)
- [CVE-2026-33579](https://insights.sbomify.com/CVE-2026-33579/): OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval (critical 9.4)
- [CVE-2026-32922](https://insights.sbomify.com/CVE-2026-32922/): OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate (critical 9.4)
- [CVE-2026-32978](https://insights.sbomify.com/CVE-2026-32978/): OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-28452 and fix it if it is affected.

What it is: CVE-2026-28452 is a medium-severity denial of service vulnerability in Openclaw Openclaw, published on 5 Mar 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-28452 in the wild and no public exploit code.

Affected packages and fixed versions:
- openclaw (npm): affected all versions; fixed in 2026.2.14
- openclaw (npm): affected all versions; fixed in 2026.2.14
- clawdbot (npm): affected all versions up to 2026.1.24-3; no fix listed
- clawdbot (npm): affected all versions up to 2026.1.24-3; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-28452/ (Markdown: https://insights.sbomify.com/CVE-2026-28452/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-28452
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-28452
- OSV: https://osv.dev/vulnerability/CVE-2026-28452

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-28452/
Summaries are generated and may contain mistakes; the official description above is the record.
