CVE-2026-28456 OpenClaw 2026.1.5 < 2026.2.14 - Arbitrary Code Execution via Unsafe Hook Module Path Handling

High 8.6 Published Updated

Attackers with gateway configuration access can execute arbitrary code by manipulating hook module paths in OpenClaw.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-28456?

CVE-2026-28456 is a high-severity code injection vulnerability in Openclaw Openclaw, published on 5 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

OpenClaw versions 2026.1.5 prior to 2026.2.14 contain a vulnerability in the Gateway in which it does not sufficiently constrain configured hook module paths before passing them to dynamic import(), allowing code execution. An attacker with gateway configuration modification access can load and execute unintended local modules in the Node.js process.

Weakness: CWE-427

Which versions are affected by CVE-2026-28456?

2 open source packages ship an affected version, including openclaw. It affects 1 product.

PackageAffectedFixed in
openclaw npmFrom 2026.1.52026.2.14
openclaw npmFrom 2026.1.52026.2.14

Products include Openclaw Openclaw.

How do I fix CVE-2026-28456?

Upgrade openclaw to 2026.2.14 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2026-28456 being exploited?

There is no known exploitation of CVE-2026-28456 in the wild and no public exploit code.

All Openclaw Openclaw vulnerabilities

Sources

Also known as GHSA-v6c6-vqqg-w888.

Is CVE-2026-28456 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free