# CVE-2026-28456: OpenClaw 2026.1.5 < 2026.2.14 - Arbitrary Code Execution via Unsafe Hook Module Path Handling

> Attackers with gateway configuration access can execute arbitrary code by manipulating hook module paths in OpenClaw.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Mar 2026
- **Updated:** 9 Mar 2026
- **Also known as:** GHSA-v6c6-vqqg-w888

## What is CVE-2026-28456?

CVE-2026-28456 is a high-severity code injection vulnerability in Openclaw Openclaw, published on 5 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

OpenClaw versions 2026.1.5 prior to 2026.2.14 contain a vulnerability in the Gateway in which it does not sufficiently constrain configured hook module paths before passing them to dynamic import(), allowing code execution. An attacker with gateway configuration modification access can load and execute unintended local modules in the Node.js process.

Weakness: CWE-427 (Uncontrolled Search Path Element)

## Which versions are affected by CVE-2026-28456?

2 open source packages ship an affected version, including openclaw. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openclaw` | npm | From 2026.1.5 | 2026.2.14 |
| `openclaw` | npm | From 2026.1.5 | 2026.2.14 |

Products: Openclaw Openclaw.

## How do I fix CVE-2026-28456?

Upgrade openclaw to 2026.2.14 or later.

## Is CVE-2026-28456 being exploited?

There is no known exploitation of CVE-2026-28456 in the wild and no public exploit code.

## Other vulnerabilities in Openclaw Openclaw

- [CVE-2026-28363](https://insights.sbomify.com/CVE-2026-28363/): Security feature bypass in OpenClaw (critical 9.9)
- [CVE-2026-30741](https://insights.sbomify.com/CVE-2026-30741/): Code injection in n/a (critical 9.8)
- [CVE-2026-33579](https://insights.sbomify.com/CVE-2026-33579/): OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval (critical 9.4)
- [CVE-2026-32922](https://insights.sbomify.com/CVE-2026-32922/): OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate (critical 9.4)
- [CVE-2026-32978](https://insights.sbomify.com/CVE-2026-32978/): OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-28456 and fix it if it is affected.

What it is: CVE-2026-28456 is a high-severity code injection vulnerability in Openclaw Openclaw, published on 5 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-28456 in the wild and no public exploit code.

Affected packages and fixed versions:
- openclaw (npm): affected from 2026.1.5; fixed in 2026.2.14
- openclaw (npm): affected from 2026.1.5; fixed in 2026.2.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-28456/ (Markdown: https://insights.sbomify.com/CVE-2026-28456/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-28456
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-28456
- OSV: https://osv.dev/vulnerability/CVE-2026-28456

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-28456/
Summaries are generated and may contain mistakes; the official description above is the record.
