# CVE-2026-28465: OpenClaw voice-call < 2026.2.3 - Webhook Verification Bypass via Forwarded Headers

> Attackers can bypass webhook verification in OpenClaw voice-call plugin by spoofing forwarded headers in reverse-proxy setups.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Mar 2026
- **Updated:** 1 Oct 2026
- **Also known as:** GHSA-3m3q-x3gj-f79x

## What is CVE-2026-28465?

CVE-2026-28465 is a high-severity authentication bypass vulnerability in Openclaw Openclaw, published on 5 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenClaw's voice-call plugin versions before 2026.2.3 contain an improper authentication vulnerability in webhook verification that allows remote attackers to bypass verification by supplying untrusted forwarded headers. Attackers can spoof webhook events by manipulating Forwarded or X-Forwarded-* headers in reverse-proxy configurations that implicitly trust these headers.

Weakness: CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2026-28465?

4 open source packages ship an affected version, including @openclaw/voice-call and @clawdbot/voice-call. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@openclaw/voice-call` | npm | All versions | 2026.2.3 |
| `@openclaw/voice-call` | npm | All versions | 2026.2.3 |
| `@clawdbot/voice-call` | npm | All versions to 2026.1.24 | None |
| `@clawdbot/voice-call` | npm | All versions to 2026.1.24 | None |

Products: Openclaw Openclaw.

## How do I fix CVE-2026-28465?

Upgrade @openclaw/voice-call to 2026.2.3 or later.

## Is CVE-2026-28465 being exploited?

There is no known exploitation of CVE-2026-28465 in the wild and no public exploit code.

## Other vulnerabilities in Openclaw Openclaw

- [CVE-2026-28363](https://insights.sbomify.com/CVE-2026-28363/): Security feature bypass in OpenClaw (critical 9.9)
- [CVE-2026-30741](https://insights.sbomify.com/CVE-2026-30741/): Code injection in n/a (critical 9.8)
- [CVE-2026-33579](https://insights.sbomify.com/CVE-2026-33579/): OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval (critical 9.4)
- [CVE-2026-32922](https://insights.sbomify.com/CVE-2026-32922/): OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate (critical 9.4)
- [CVE-2026-32978](https://insights.sbomify.com/CVE-2026-32978/): OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-28465 and fix it if it is affected.

What it is: CVE-2026-28465 is a high-severity authentication bypass vulnerability in Openclaw Openclaw, published on 5 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-28465 in the wild and no public exploit code.

Affected packages and fixed versions:
- @openclaw/voice-call (npm): affected all versions; fixed in 2026.2.3
- @openclaw/voice-call (npm): affected all versions; fixed in 2026.2.3
- @clawdbot/voice-call (npm): affected all versions up to 2026.1.24; no fix listed
- @clawdbot/voice-call (npm): affected all versions up to 2026.1.24; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-28465/ (Markdown: https://insights.sbomify.com/CVE-2026-28465/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-28465
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-28465
- OSV: https://osv.dev/vulnerability/CVE-2026-28465

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-28465/
Summaries are generated and may contain mistakes; the official description above is the record.
