CVE-2026-28469 OpenClaw < 2026.2.14 - Cross-Account Policy Context Misrouting via Shared Webhook Path Ambiguity

High 8.2 Published Updated

Attackers can bypass account-specific allowlists and session policies by exploiting webhook path ambiguity, leading to unauthorized access to cross-account data.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-28469?

CVE-2026-28469 is a high-severity authentication bypass vulnerability in Openclaw Openclaw, published on 5 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

OpenClaw versions prior to 2026.2.14 contain a webhook routing vulnerability in the Google Chat monitor component that allows cross-account policy context misrouting when multiple webhook targets share the same HTTP path. Attackers can exploit first-match request verification semantics to process inbound webhook events under incorrect account contexts, bypassing intended allowlists and session policies.

Weakness: CWE-639

Which versions are affected by CVE-2026-28469?

4 open source packages ship an affected version, including openclaw and clawdbot. It affects 1 product.

PackageAffectedFixed in
openclaw npmAll versions2026.2.14
openclaw npmAll versions2026.2.14
clawdbot npmAll versions to 2026.1.24-3None
clawdbot npmAll versions to 2026.1.24-3None

Products include Openclaw Openclaw.

How do I fix CVE-2026-28469?

Upgrade openclaw to 2026.2.14 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2026-28469 being exploited?

There is no known exploitation of CVE-2026-28469 in the wild and no public exploit code.

All Openclaw Openclaw vulnerabilities

Sources

Also known as GHSA-rq6g-px6m-c248.

Is CVE-2026-28469 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free