CVE-2026-28478 OpenClaw < 2026.2.13 - Denial of Service via Unbounded Webhook Request Body Buffering

High 8.7 Published Updated

Remote attackers can cause denial of service in OpenClaw by sending oversized or slow webhook requests, exhausting server memory.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-28478?

CVE-2026-28478 is a high-severity denial of service vulnerability in Openclaw Openclaw, published on 5 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

OpenClaw versions prior to 2026.2.13 contain a denial of service vulnerability in webhook handlers that buffer request bodies without strict byte or time limits. Remote unauthenticated attackers can send oversized JSON payloads or slow uploads to webhook endpoints causing memory pressure and availability degradation.

Weakness: CWE-770

Which versions are affected by CVE-2026-28478?

4 open source packages ship an affected version, including openclaw and clawdbot. It affects 1 product.

PackageAffectedFixed in
openclaw npmAll versions2026.2.13
openclaw npmAll versions2026.2.13
clawdbot npmAll versions to 2026.1.24-3None
clawdbot npmAll versions to 2026.1.24-3None

Products include Openclaw Openclaw.

How do I fix CVE-2026-28478?

Upgrade openclaw to 2026.2.13 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-28478 being exploited?

There is no known exploitation of CVE-2026-28478 in the wild and no public exploit code.

All Openclaw Openclaw vulnerabilities

Sources

Also known as GHSA-q447-rj3r-2cgh.

Is CVE-2026-28478 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free