# CVE-2026-28490: Authlib Vulnerable to JWE RSA1_5 Bleichenbacher Padding Oracle

> Attackers can exploit a padding oracle in Authlib's RSA1_5 JWE implementation to decrypt sensitive data or bypass security controls.

- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Mar 2026
- **Updated:** 16 Mar 2026
- **Also known as:** DEBIAN-CVE-2026-28490, ECHO-c9a3-95ec-f0d8, GHSA-7432-952r-cw78, MINI-3r7v-h68c-mcg4, MINI-jfr7-chc9-99vr, PYSEC-2026-2116, ROOT-APP-PYPI-CVE-2026-28490, UBUNTU-CVE-2026-28490

## What is CVE-2026-28490?

CVE-2026-28490 is a high-severity vulnerability in authlib, published on 16 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Authlib is a Python library which builds OAuth and OpenID Connect servers. Prior to version 1.6.9, a cryptographic padding oracle vulnerability was identified in the Authlib Python library concerning the implementation of the JSON Web Encryption (JWE) RSA1_5 key management algorithm. Authlib registers RSA1_5 in its default algorithm registry without requiring explicit opt-in, and actively destroys the constant-time Bleichenbacher mitigation that the underlying cryptography library implements correctly. This issue has been patched in version 1.6.9.

Weakness: CWE-327 (Use of a Broken or Risky Cryptographic Algorithm), CWE-203 (Observable Discrepancy)

## Which versions are affected by CVE-2026-28490?

3 open source packages ship an affected version, including authlib. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `authlib` | PyPI | All versions | 1.6.9 |
| `authlib` | PyPI | All versions | 1.6.9 |
| `authlib` | PyPI | All versions | 1.6.9 |

Products: Authlib Authlib.

## How do I fix CVE-2026-28490?

Upgrade authlib to 1.6.9 or later.

## Is CVE-2026-28490 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-28490 exists.

## Other vulnerabilities in authlib

- [CVE-2026-27962](https://insights.sbomify.com/CVE-2026-27962/): Authlib JWS JWK Header Injection: Signature Verification Bypass (critical 9.1)
- [CVE-2026-28498](https://insights.sbomify.com/CVE-2026-28498/): Authlib: Fail-Open Cryptographic Verification in OIDC Hash Binding (high 8.2)
- [CVE-2026-28802](https://insights.sbomify.com/CVE-2026-28802/): Authlib: Setting `alg: none` and a blank signature appears to bypass signature verification (high 7.7)
- [CVE-2025-61920](https://insights.sbomify.com/CVE-2025-61920/): Authlib is vulnerable to Denial of Service via Oversized JOSE Segments (high 7.5)
- [CVE-2025-59420](https://insights.sbomify.com/CVE-2025-59420/): Authlib: JWS/JWT accepts unknown crit headers (RFC violation → possible authz bypass) (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-28490 and fix it if it is affected.

What it is: CVE-2026-28490 is a high-severity vulnerability in authlib, published on 16 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-28490 exists.

Affected packages and fixed versions:
- authlib (PyPI): affected all versions; fixed in 1.6.9
- authlib (PyPI): affected all versions; fixed in 1.6.9
- authlib (PyPI): affected all versions; fixed in 1.6.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-28490/ (Markdown: https://insights.sbomify.com/CVE-2026-28490/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-28490
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-28490
- OSV: https://osv.dev/vulnerability/CVE-2026-28490

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-28490/
Summaries are generated and may contain mistakes; the official description above is the record.
