# CVE-2026-28498: Authlib: Fail-Open Cryptographic Verification in OIDC Hash Binding

> Attackers can bypass OIDC token integrity checks by using unsupported algorithms, allowing forged tokens to be accepted as valid.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Mar 2026
- **Updated:** 10 Sep 2026
- **Also known as:** DEBIAN-CVE-2026-28498, ECHO-435f-9eb9-99cb, GHSA-m344-f55w-2m6j, MINI-84m5-6586-wq2f, MINI-hr69-68cq-v4wq, PYSEC-2026-2117, ROOT-APP-PYPI-CVE-2026-28498, UBUNTU-CVE-2026-28498

## What is CVE-2026-28498?

CVE-2026-28498 is a high-severity vulnerability in authlib, published on 16 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Authlib is a Python library which builds OAuth and OpenID Connect servers. Prior to version 1.6.9, a library-level vulnerability was identified in the Authlib Python library concerning the validation of OpenID Connect (OIDC) ID Tokens. Specifically, the internal hash verification logic (_verify_hash) responsible for validating the at_hash (Access Token Hash) and c_hash (Authorization Code Hash) claims exhibits a fail-open behavior when encountering an unsupported or unknown cryptographic algorithm. This flaw allows an attacker to bypass mandatory integrity protections by supplying a forged ID Token with a deliberately unrecognized alg header parameter. The library intercepts the unsupported state and silently returns True (validation passed), inherently violating fundamental cryptographic design principles and direct OIDC specifications. This issue has been patched in version 1.6.9.

Weakness: CWE-325 (Missing Cryptographic Step), CWE-573 (Improper Following of Specification by Caller), CWE-354 (Improper Validation of Integrity Check Value)

## Which versions are affected by CVE-2026-28498?

3 open source packages ship an affected version, including authlib. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `authlib` | PyPI | All versions | 1.6.9 |
| `authlib` | PyPI | All versions | 1.6.9 |
| `authlib` | PyPI | All versions | 1.6.9 |

Products: Authlib Authlib.

## How do I fix CVE-2026-28498?

Upgrade authlib to 1.6.9 or later.

## Is CVE-2026-28498 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-28498 exists.

## Other vulnerabilities in authlib

- [CVE-2026-27962](https://insights.sbomify.com/CVE-2026-27962/): Authlib JWS JWK Header Injection: Signature Verification Bypass (critical 9.1)
- [CVE-2026-28490](https://insights.sbomify.com/CVE-2026-28490/): Authlib Vulnerable to JWE RSA1_5 Bleichenbacher Padding Oracle (high 8.3)
- [CVE-2026-28802](https://insights.sbomify.com/CVE-2026-28802/): Authlib: Setting `alg: none` and a blank signature appears to bypass signature verification (high 7.7)
- [CVE-2025-61920](https://insights.sbomify.com/CVE-2025-61920/): Authlib is vulnerable to Denial of Service via Oversized JOSE Segments (high 7.5)
- [CVE-2025-59420](https://insights.sbomify.com/CVE-2025-59420/): Authlib: JWS/JWT accepts unknown crit headers (RFC violation → possible authz bypass) (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-28498 and fix it if it is affected.

What it is: CVE-2026-28498 is a high-severity vulnerability in authlib, published on 16 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-28498 exists.

Affected packages and fixed versions:
- authlib (PyPI): affected all versions; fixed in 1.6.9
- authlib (PyPI): affected all versions; fixed in 1.6.9
- authlib (PyPI): affected all versions; fixed in 1.6.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-28498/ (Markdown: https://insights.sbomify.com/CVE-2026-28498/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-28498
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-28498
- OSV: https://osv.dev/vulnerability/CVE-2026-28498

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-28498/
Summaries are generated and may contain mistakes; the official description above is the record.
