# CVE-2026-28500: ONNX Untrusted Model Repository Warnings Suppressed by silent=True in onnx.hub.load() — Silent Supply-Chain Attack

> Attackers can silently load malicious models via onnx.hub.load() with silent=True, bypassing security warnings to exfiltrate data or execute code.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Mar 2026
- **Updated:** 15 Jul 2026
- **Also known as:** DEBIAN-CVE-2026-28500, ECHO-a2aa-110f-94f8, GHSA-hqmj-h5c6-369m, PYSEC-2026-103, UBUNTU-CVE-2026-28500

## What is CVE-2026-28500?

CVE-2026-28500 is a high-severity vulnerability in onnx, published on 18 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Open Neural Network Exchange (ONNX) is an open standard for machine learning interoperability. In versions up to and including 1.20.1, a security control bypass exists in onnx.hub.load() due to improper logic in the repository trust verification mechanism. While the function is designed to warn users when loading models from non-official sources, the use of the silent=True parameter completely suppresses all security warnings and confirmation prompts. This vulnerability transforms a standard model-loading function into a vector for Zero-Interaction Supply-Chain Attacks. When chained with file-system vulnerabilities, an attacker can silently exfiltrate sensitive files (SSH keys, cloud credentials) from the victim's machine the moment the model is loaded. As of time of publication, no known patched versions are available.

Weakness: CWE-829 (Inclusion of Functionality from Untrusted Control Sphere), CWE-693 (Protection Mechanism Failure), CWE-494 (Download of Code Without Integrity Check), CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2026-28500?

3 open source packages ship an affected version, including onnx. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `onnx` | PyPI | All versions | 1.21.0rc1 |
| `onnx` | PyPI | All versions | 1.21.0rc1 |
| `onnx` | PyPI | All versions | 1.21.0rc1 |

Products: Linuxfoundation Onnx.

## How do I fix CVE-2026-28500?

Upgrade onnx to 1.21.0rc1 or later.

## Is CVE-2026-28500 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-28500 exists.

## Other vulnerabilities in onnx

- [CVE-2025-51480](https://insights.sbomify.com/CVE-2025-51480/): Path traversal in n/a (high 8.8)
- [CVE-2024-5187](https://insights.sbomify.com/CVE-2024-5187/): Arbitrary File Overwrite in download_model_with_test_data in onnx/onnx (high 8.8)
- [CVE-2026-27489](https://insights.sbomify.com/CVE-2026-27489/): ONNX: Path Traversal via Symlink (high 8.7)
- [CVE-2026-34445](https://insights.sbomify.com/CVE-2026-34445/): ONNX: Malicious ONNX models can crash servers by exploiting unprotected object settings. (high 8.6)
- [CVE-2022-25882](https://insights.sbomify.com/CVE-2022-25882/): Directory Traversal in onnx (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-28500 and fix it if it is affected.

What it is: CVE-2026-28500 is a high-severity vulnerability in onnx, published on 18 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-28500 exists.

Affected packages and fixed versions:
- onnx (PyPI): affected all versions; fixed in 1.21.0rc1
- onnx (PyPI): affected all versions; fixed in 1.21.0rc1
- onnx (PyPI): affected all versions; fixed in 1.21.0rc1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-28500/ (Markdown: https://insights.sbomify.com/CVE-2026-28500/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-28500
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-28500
- OSV: https://osv.dev/vulnerability/CVE-2026-28500

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-28500/
Summaries are generated and may contain mistakes; the official description above is the record.
