CVE-2026-28507 Idno: Remote Code Execution via Chained Import File Write and Template Path Traversal
High 8.6
Published
Updated
Check this codebase for CVE-2026-28507 and fix it if it is affected.
What it is: CVE-2026-28507 is a high-severity vulnerability in idno, published on 6 Mar 2026.
Exploitation: There is no known exploitation of CVE-2026-28507 in the wild and no public exploit code.
Affected packages and fixed versions:
- idno/known (Packagist): affected all versions; fixed in 1.6.4
- idno/known (Packagist): affected all versions; fixed in 1.6.4
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2026-28507/ (Markdown: https://insights.sbomify.com/CVE-2026-28507/index.md)
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2026-28507?
CVE-2026-28507 is a high-severity vulnerability in idno, published on 6 Mar 2026.
Official description
Idno is a social publishing platform. Prior to version 1.6.4, there is a remote code execution vulnerability via chained import file write and template path traversal. This issue has been patched in version 1.6.4.
Weakness: CWE-78
Which versions are affected by CVE-2026-28507?
2 open source packages ship an affected version, including idno/known. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
idno/known Packagist | All versions | 1.6.4 |
idno/known Packagist | All versions | 1.6.4 |
Products include Withknown Known.
How do I fix CVE-2026-28507?
Upgrade idno/known to 1.6.4 or later.
Is CVE-2026-28507 being exploited?
There is no known exploitation of CVE-2026-28507 in the wild and no public exploit code.
Other vulnerabilities in idno
- CVE-2026-26273 Known affected by Account Takeover via Password Reset Token Leakage
- CVE-2026-28508 Idno: Unauthenticated SSRF via URL Unfurl Endpoint
- CVE-2022-33011 Known vulnerable to account takeover via host header injection attack in v1.3.1
- CVE-2022-32115 Known vulnerable to code execution via SVG file in v1.3.1
- CVE-2022-31290 Known v1.3.1 Cross-site Scripting
Sources
Also known as GHSA-37j7-56xc-c468.