{"answers":{"affected":"3 open source packages ship an affected version, including github.com/pocket-id/pocket-id/backend. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-28513 exists.","fix":"Upgrade github.com/pocket-id/pocket-id/backend to 0.0.0-20260307173642-b59e35cb59ae or later.","what":"CVE-2026-28513 is a high-severity authentication bypass vulnerability in pocket-id, published on 9 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-28513 and fix it if it is affected.\n\nWhat it is: CVE-2026-28513 is a high-severity authentication bypass vulnerability in pocket-id, published on 9 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-28513 exists.\n\nAffected packages and fixed versions:\n- github.com/pocket-id/pocket-id/backend (Go): affected all versions; fixed in 0.0.0-20260307173642-b59e35cb59ae\n- github.com/pocket-id/pocket-id/backend (Go): affected all versions; fixed in 0.0.0-20260307173642-b59e35cb59ae\n- github.com/pocket-id/pocket-id/backend (Go): affected all versions; fixed in 0.0.0-20260307173642-b59e35cb59ae\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-28513/ (Markdown: https://insights.sbomify.com/CVE-2026-28513/index.md)","id":"CVE-2026-28513","markdown":"https://insights.sbomify.com/CVE-2026-28513/index.md","name":"CVE-2026-28513","record":{"aliases":["GHSA-qh6q-598w-w6m2","GO-2026-4656"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["account_takeover","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"OIDC identity provider","requires_auth":"low_privilege","summary":"Attackers can exchange authorization codes across clients or reuse expired codes due to flawed validation logic, potentially leading to unauthorized access.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"pocket_id","vendor":"pocket-id"}],"cvss":{"score":8.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"Pocket ID is an OIDC provider that allows users to authenticate with their passkeys to your services. Prior to 2.4.0, the OIDC token endpoint rejects an authorization code only when both the client ID is wrong and the code is expired. This allows cross-client code exchange and expired code reuse. This vulnerability is fixed in 2.4.0.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Pocket ID: OIDC authorization code validation uses AND instead of OR, allowing cross-client token exchange","id":"CVE-2026-28513","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":3,"n_references":1,"next":{"headline":"Rocket.Chat: Users can login with any password via the EE ddp-streamer-service","id":"CVE-2026-28514"},"packages":[{"ecosystem":"Go","fixed":["0.0.0-20260307173642-b59e35cb59ae"],"introduced":["0"],"last_affected":[],"package":"github.com/pocket-id/pocket-id/backend","purl":null,"source":"GHSA-qh6q-598w-w6m2"},{"ecosystem":"Go","fixed":["0.0.0-20260307173642-b59e35cb59ae"],"introduced":["0"],"last_affected":[],"package":"github.com/pocket-id/pocket-id/backend","purl":"pkg:golang/github.com/pocket-id/pocket-id/backend","source":"GHSA-qh6q-598w-w6m2"},{"ecosystem":"Go","fixed":["0.0.0-20260307173642-b59e35cb59ae"],"introduced":["0"],"last_affected":[],"package":"github.com/pocket-id/pocket-id/backend","purl":"pkg:golang/github.com/pocket-id/pocket-id/backend","source":"GO-2026-4656"}],"prev":{"headline":"Pocket ID: OAuth redirect_uri validation bypass via userinfo/host confusion","id":"CVE-2026-28512"},"products":["pocket-id"],"published":"2026-03-09","related":[{"cvss_score":8.5,"headline":"Pocket ID: OIDC refresh token flow bypasses authorization revocation, account disabling, and group restrictions","id":"CVE-2026-43983","kev_date_added":null,"published":"2026-05-12"},{"cvss_score":7.1,"headline":"Pocket ID: OAuth redirect_uri validation bypass via userinfo/host confusion","id":"CVE-2026-28512","kev_date_added":null,"published":"2026-03-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-10","vendors":["pocket-id"]},"summary":"Attackers can exchange authorization codes across clients or reuse expired codes due to flawed validation logic, potentially leading to unauthorized access.","url":"https://insights.sbomify.com/CVE-2026-28513/"}