# CVE-2026-28515: openDCIM <= 23.04 Missing Authorization in install.php

> Authenticated users can modify LDAP configuration in openDCIM due to missing authorization checks in installer scripts.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 27 Feb 2026
- **Updated:** 14 Jul 2026
- **Also known as:** GHSA-mg2w-x76x-59h8

## What is CVE-2026-28515?

CVE-2026-28515 is a critical missing authorization vulnerability in openDCIM, published on 27 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

openDCIM version 23.04, through commit 4467e9c4, contains a missing authorization vulnerability in install.php and container-install.php. The installer and upgrade handler expose LDAP configuration functionality without enforcing application role checks. Any authenticated user can access this functionality regardless of assigned privileges. In deployments where REMOTE_USER is set without authentication enforcement, the endpoint may be accessible without credentials. This allows unauthorized modification of application configuration.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-28515?

It affects 1 product.


Products: Opendcim Opendcim.

## How do I fix CVE-2026-28515?

No fix has been published for CVE-2026-28515 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-28515 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-28515 exists.

Public exploit code:

- openDCIM install.php SQL Injection to RCE (metasploit)

## Other vulnerabilities in openDCIM

- [CVE-2026-28516](https://insights.sbomify.com/CVE-2026-28516/): openDCIM <= 23.04 SQL Injection in Config::UpdateParameter (critical 9.3)
- [CVE-2026-28517](https://insights.sbomify.com/CVE-2026-28517/): openDCIM <= 23.04 OS Command Injection via dot Configuration Parameter (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-28515 and fix it if it is affected.

What it is: CVE-2026-28515 is a critical missing authorization vulnerability in openDCIM, published on 27 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-28515 exists.

Affected product: openDCIM. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-28515/ (Markdown: https://insights.sbomify.com/CVE-2026-28515/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-28515
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-28515
- OSV: https://osv.dev/vulnerability/CVE-2026-28515

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-28515/
Summaries are generated and may contain mistakes; the official description above is the record.
