# CVE-2026-28517: openDCIM <= 23.04 OS Command Injection via dot Configuration Parameter

> Attackers with database write access can execute arbitrary OS commands via the dot configuration parameter in openDCIM.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 27 Feb 2026
- **Updated:** 14 Jul 2026
- **Also known as:** GHSA-428h-8xhf-g3cw

## What is CVE-2026-28517?

CVE-2026-28517 is a critical command injection vulnerability in openDCIM, published on 27 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

openDCIM version 23.04, through commit 4467e9c4, contains an OS command injection vulnerability in report_network_map.php. The application retrieves the 'dot' configuration parameter from the database and passes it directly to exec() without validation or sanitization. If an attacker can modify the fac_Config.dot value, arbitrary commands may be executed in the context of the web server process.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-28517?

It affects 1 product.


Products: Opendcim Opendcim.

## How do I fix CVE-2026-28517?

No fix has been published for CVE-2026-28517 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-28517 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-28517 exists.

Public exploit code:

- openDCIM install.php SQL Injection to RCE (metasploit)

## Other vulnerabilities in openDCIM

- [CVE-2026-28515](https://insights.sbomify.com/CVE-2026-28515/): openDCIM <= 23.04 Missing Authorization in install.php (critical 9.3)
- [CVE-2026-28516](https://insights.sbomify.com/CVE-2026-28516/): openDCIM <= 23.04 SQL Injection in Config::UpdateParameter (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-28517 and fix it if it is affected.

What it is: CVE-2026-28517 is a critical command injection vulnerability in openDCIM, published on 27 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-28517 exists.

Affected product: openDCIM. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-28517/ (Markdown: https://insights.sbomify.com/CVE-2026-28517/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-28517
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-28517
- OSV: https://osv.dev/vulnerability/CVE-2026-28517

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-28517/
Summaries are generated and may contain mistakes; the official description above is the record.
