CVE-2026-28563 Apache Airflow: DAG authorization bypass

Medium 4.3 Published Updated

Authenticated users can enumerate unauthorized DAGs via the dependencies endpoint, exposing sensitive workflow structures.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-28563?

CVE-2026-28563 is a medium-severity missing authorization vulnerability in Apache Airflow, published on 17 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Apache Airflow versions 3.1.0 through 3.1.7 /ui/dependencies endpoint returns the full DAG dependency graph without filtering by authorized DAG IDs. This allows an authenticated user with only DAG Dependencies permission to enumerate DAGs they are not authorized to view.

Users are recommended to upgrade to Apache Airflow 3.1.8 or later, which resolves this issue.

Weakness: CWE-732

Which versions are affected by CVE-2026-28563?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.

PackageAffectedFixed in
apache-airflow PyPIFrom 3.0.03.1.8
apache-airflow PyPIFrom 3.0.03.1.8
apache-airflow PyPIFrom 3.0.03.1.8
airflow BitnamiFrom 3.0.03.1.8

Products include Apache Airflow.

How do I fix CVE-2026-28563?

Upgrade apache-airflow to 3.1.8 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-28563 being exploited?

There is no known exploitation of CVE-2026-28563 in the wild and no public exploit code.

All Apache Airflow vulnerabilities

Sources

Also known as BIT-airflow-2026-28563, ECHO-9ac2-76f0-f382, GHSA-x3fv-96qh-67m7, MINI-8wqr-3g57-9pqx, PYSEC-2026-15.

Is CVE-2026-28563 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free