# CVE-2026-28564: Apache IoTDB: REST Basic Authentication Accepts Stale Cached Credentials

> Attackers can bypass authentication in Apache IoTDB by replaying stale cached credentials, allowing unauthorized access to the database.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 10 Jul 2026
- **Updated:** 10 Jul 2026
- **Also known as:** GHSA-xwqh-5v9q-g7v9

## What is CVE-2026-28564?

CVE-2026-28564 is a critical authentication bypass vulnerability in Apache IoTDB, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Insufficient Session Expiration, Authentication Bypass by Capture-replay vulnerability in Apache IoTDB.
REST Basic Authentication Accepts Stale Cached Credentials

This issue affects Apache IoTDB: from 1.0.0 before 2.0.10.

Users are recommended to upgrade to version 2.0.10, which fixes the issue.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration), CWE-294 (Authentication Bypass by Capture-replay)

## Which versions are affected by CVE-2026-28564?


## How do I fix CVE-2026-28564?

No fix has been published for CVE-2026-28564 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-28564 being exploited?

There is no known exploitation of CVE-2026-28564 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-28564 and fix it if it is affected.

What it is: CVE-2026-28564 is a critical authentication bypass vulnerability in Apache IoTDB, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-28564 in the wild and no public exploit code.

Affected product: Apache IoTDB. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-28564/ (Markdown: https://insights.sbomify.com/CVE-2026-28564/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-28564
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-28564
- OSV: https://osv.dev/vulnerability/CVE-2026-28564

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-28564/
Summaries are generated and may contain mistakes; the official description above is the record.
