# CVE-2026-28681: IRRd: web UI host header injection allows password reset poisoning via attacker-controlled email links

> Attackers can poison password reset links via Host header injection to steal tokens and take over user accounts, allowing modification of routing registry objects.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Mar 2026
- **Updated:** 6 Mar 2026
- **Also known as:** GHSA-22m3-c7vp-49fj, PYSEC-2026-2186

## What is CVE-2026-28681?

CVE-2026-28681 is a high-severity vulnerability in irrdnet irrd, published on 6 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Internet Routing Registry daemon version 4 is an IRR database server, processing IRR objects in the RPSL format. From version 4.4.0 to before version 4.4.5 and from version 4.5.0 to before version 4.5.1, an attacker can manipulate the HTTP Host header on a password reset or account creation request. The confirmation link in the resulting email can then point to an attacker-controlled domain. Opening the link in the email is sufficient to pass the token to the attacker, who can then use it on the real IRRD instance to take over the account. A compromised account can then be used to modify RPSL objects maintained by the account's mntners and perform other account actions. If the user had two-factor authentication configured, which is required for users with override access, an attacker is not able to log in, even after successfully resetting the password. This issue has been patched in versions 4.4.5 and 4.5.1.

Weakness: CWE-640 (Weak Password Recovery Mechanism for Forgotten Password), CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2026-28681?

5 open source packages ship an affected version, including irrd. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `irrd` | PyPI | From 4.4.0 | 4.4.5, 4.5.1 |
| `irrd` | PyPI | From 4.4.0 | 4.4.5 |
| `irrd` | PyPI | From 4.4.0 | 4.4.5 |
| `irrd` | PyPI | From 4.5.0 | 4.5.1 |
| `irrd` | PyPI | From 4.5.0 | 4.5.1 |

Products: Internet Routing Registry Daemon Project Internet Routing Registry Daemon.

## How do I fix CVE-2026-28681?

Upgrade irrd to a fixed version for your release line: 4.4.5 or 4.5.1.

## Is CVE-2026-28681 being exploited?

There is no known exploitation of CVE-2026-28681 in the wild and no public exploit code.

## Other vulnerabilities in irrdnet irrd

- [CVE-2022-24798](https://insights.sbomify.com/CVE-2022-24798/): Insufficient password hash filtering in some IRRd queries and exports (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-28681 and fix it if it is affected.

What it is: CVE-2026-28681 is a high-severity vulnerability in irrdnet irrd, published on 6 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-28681 in the wild and no public exploit code.

Affected packages and fixed versions:
- irrd (PyPI): affected from 4.4.0; fixed in 4.4.5, 4.5.1
- irrd (PyPI): affected from 4.4.0; fixed in 4.4.5
- irrd (PyPI): affected from 4.4.0; fixed in 4.4.5
- irrd (PyPI): affected from 4.5.0; fixed in 4.5.1
- irrd (PyPI): affected from 4.5.0; fixed in 4.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-28681/ (Markdown: https://insights.sbomify.com/CVE-2026-28681/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-28681
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-28681
- OSV: https://osv.dev/vulnerability/CVE-2026-28681

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-28681/
Summaries are generated and may contain mistakes; the official description above is the record.
