{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-2869 exists.","fix":"No fix has been published for CVE-2026-2869 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-2869 is a medium-severity memory corruption vulnerability in janet-lang janet, published on 21 Feb 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-2869 and fix it if it is affected.\n\nWhat it is: CVE-2026-2869 is a medium-severity memory corruption vulnerability in janet-lang janet, published on 21 Feb 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-2869 exists.\n\nAffected product: janet-lang janet. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-2869/ (Markdown: https://insights.sbomify.com/CVE-2026-2869/index.md)","id":"CVE-2026-2869","markdown":"https://insights.sbomify.com/CVE-2026-2869/index.md","name":"CVE-2026-2869","record":{"aliases":["GHSA-925f-q35m-63gx"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Janet programming language","requires_auth":"low_privilege","summary":"A local attacker can trigger an out-of-bounds read in the Janet language interpreter, potentially causing crashes or leaking memory.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"janet","vendor":"janet-lang"}],"cvss":{"score":4.8,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"},{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"A vulnerability was identified in janet-lang janet up to 1.40.1. Affected by this vulnerability is the function janetc_varset of the file src/core/specials.c of the component handleattr Handler. The manipulation leads to out-of-bounds read. The attack can only be performed from a local environment. The exploit is publicly available and might be used. Upgrading to version 1.41.0 addresses this issue. The identifier of the patch is 2fabc80151a2b8834ee59cda8a70453f848b40e5. The affected component should be upgraded.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"janet-lang janet handleattr specials.c janetc_varset out-of-bounds","id":"CVE-2026-2869","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2026"},"n_packages":0,"n_references":8,"next":{"headline":"Tenda A21 formSetQosBand set_qosMib_list stack-based overflow","id":"CVE-2026-2870"},"packages":[],"prev":{"headline":"Cross-site scripting in Gutenverse – Ultimate WordPress FSE Blocks Addons \u0026 Ecosystem","id":"CVE-2026-2868"},"products":["janet"],"published":"2026-02-21","related":[{"cvss_score":7.5,"headline":"Janet before 1.22.0 mishandles arrays.","id":"CVE-2022-30763","kev_date_added":null,"published":"2022-05-16"},{"cvss_score":4.8,"headline":"janet-lang janet compile.c janetc_pop_funcdef out-of-bounds","id":"CVE-2026-2240","kev_date_added":null,"published":"2026-02-09"},{"cvss_score":4.8,"headline":"janet-lang janet os.c os_strftime out-of-bounds","id":"CVE-2026-2241","kev_date_added":null,"published":"2026-02-09"},{"cvss_score":4.8,"headline":"janet-lang janet specials.c janetc_if out-of-bounds","id":"CVE-2026-2242","kev_date_added":null,"published":"2026-02-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-02-23","vendors":["janet-lang"]},"summary":"A local attacker can trigger an out-of-bounds read in the Janet language interpreter, potentially causing crashes or leaking memory.","url":"https://insights.sbomify.com/CVE-2026-2869/"}