# CVE-2026-28697: Craft Affected by Authenticated RCE via "craft.app.fs.write()" in Twig Templates

> Authenticated administrators can achieve remote code execution in Craft CMS by injecting Server-Side Template Injection payloads into Twig templates.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Mar 2026
- **Updated:** 6 Mar 2026
- **Also known as:** GHSA-v47q-jxvr-p68x

## What is CVE-2026-28697?

CVE-2026-28697 is a critical code injection vulnerability in Craftcms Craft Cms, published on 4 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Craft is a content management system (CMS). Prior to 4.17.0-beta.1 and 5.9.0-beta.1, an authenticated administrator can achieve Remote Code Execution (RCE) by injecting a Server-Side Template Injection (SSTI) payload into Twig template fields (e.g., Email Templates). By calling the craft.app.fs.write() method, an attacker can write a malicious PHP script to a web-accessible directory and subsequently access it via the browser to execute arbitrary system commands. This vulnerability is fixed in 4.17.0-beta.1 and 5.9.0-beta.1.

Weakness: CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2026-28697?

4 open source packages ship an affected version, including craftcms/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/cms` | Packagist | From 4.0.0-RC1 | 4.17.0-beta.1 |
| `craftcms/cms` | Packagist | From 4.0.0-RC1 | 4.17.0-beta.1 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.9.0-beta.1 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.9.0-beta.1 |

Products: Craftcms Craft Cms.

## How do I fix CVE-2026-28697?

Upgrade craftcms/cms to a fixed version for your release line: 4.17.0-beta.1 or 5.9.0-beta.1.

## Is CVE-2026-28697 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-28697 exists.

## Other vulnerabilities in Craftcms Craft Cms

- [CVE-2025-32432](https://insights.sbomify.com/CVE-2025-32432/): Craft CMS Code Injection (critical 10.0, exploited in the wild)
- [CVE-2024-56145](https://insights.sbomify.com/CVE-2024-56145/): Craft CMS Code Injection (critical 9.3, exploited in the wild)
- [CVE-2025-23209](https://insights.sbomify.com/CVE-2025-23209/): Craft CMS Code Injection (high 8.1, exploited in the wild)
- [CVE-2025-35939](https://insights.sbomify.com/CVE-2025-35939/): Craft CMS External Control of Assumed-Immutable Web Parameter (medium 6.9, exploited in the wild)
- [CVE-2023-41892](https://insights.sbomify.com/CVE-2023-41892/): Craft CMS Remote Code Execution vulnerability (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-28697 and fix it if it is affected.

What it is: CVE-2026-28697 is a critical code injection vulnerability in Craftcms Craft Cms, published on 4 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-28697 exists.

Affected packages and fixed versions:
- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.17.0-beta.1
- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.17.0-beta.1
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.9.0-beta.1
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.9.0-beta.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-28697/ (Markdown: https://insights.sbomify.com/CVE-2026-28697/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-28697
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-28697
- OSV: https://osv.dev/vulnerability/CVE-2026-28697

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-28697/
Summaries are generated and may contain mistakes; the official description above is the record.
