# CVE-2026-28699: Gitea Basic Auth bypasses OAuth2 access token scopes

> Attackers can bypass OAuth2 access token scope restrictions by using HTTP Basic authentication, potentially gaining unauthorized access to resources.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jul 2026
- **Updated:** 6 Jul 2026
- **Also known as:** GHSA-9r5x-wg6m-x2rc, GO-2026-5299

## What is CVE-2026-28699?

CVE-2026-28699 is a high-severity authentication bypass vulnerability in Gitea Open Source Git Server, published on 3 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Gitea versions up to and including 1.26.1 allow OAuth2 access token scope enforcement to be bypassed through HTTP Basic authentication.

Weakness: CWE-863 (Incorrect Authorization), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-28699?

3 open source packages ship an affected version, including code.gitea.io/gitea.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `code.gitea.io/gitea` | Go | All versions | 1.26.2 |
| `code.gitea.io/gitea` | Go | All versions | 1.26.2 |
| `code.gitea.io/gitea` | Go | All versions | 1.26.2 |

## How do I fix CVE-2026-28699?

Upgrade code.gitea.io/gitea to 1.26.2 or later.

## Is CVE-2026-28699 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-28699 exists.

Public exploit code:

- Lab + writeup for CVE-2026-28699: Gitea OAuth2 scope enforcement bypass via HTTP Basic auth (github_poc): https://github.com/Alardiians/gitea-CVE-2026-28699

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-28699 and fix it if it is affected.

What it is: CVE-2026-28699 is a high-severity authentication bypass vulnerability in Gitea Open Source Git Server, published on 3 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-28699 exists.

Affected packages and fixed versions:
- code.gitea.io/gitea (Go): affected all versions; fixed in 1.26.2
- code.gitea.io/gitea (Go): affected all versions; fixed in 1.26.2
- code.gitea.io/gitea (Go): affected all versions; fixed in 1.26.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-28699/ (Markdown: https://insights.sbomify.com/CVE-2026-28699/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-28699
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-28699
- OSV: https://osv.dev/vulnerability/CVE-2026-28699

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-28699/
Summaries are generated and may contain mistakes; the official description above is the record.
