CVE-2026-28741 CSRF Protection Bypass Allows Updating a User's Authentication Method
Attackers can bypass CSRF protection to change a user's authentication method, potentially leading to account takeover.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-28741?
CVE-2026-28741 is a medium-severity vulnerability in Mattermost Mattermost Server, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Mattermost versions 10.11.x <= 10.11.12, 11.5.x <= 11.5.0, 11.4.x <= 11.4.2, 11.3.x <= 11.3.2 fail to validate CSRF tokens on an authentication endpoint which allows an attacker to update a user's authentication method via a CSRF attack by tricking a user into visiting a malicious page. Mattermost Advisory ID: MMSA-2026-00625
Weakness: CWE-352
Which versions are affected by CVE-2026-28741?
12 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost/server/v8 Go | From 11.3.0-rc1 | 11.3.3 |
github.com/mattermost/mattermost/server/v8 Go | From 11.3.0-rc1 | 11.3.3 |
github.com/mattermost/mattermost/server/v8 Go | From 11.4.0-rc1 | 11.4.3 |
github.com/mattermost/mattermost/server/v8 Go | From 11.4.0-rc1 | 11.4.3 |
github.com/mattermost/mattermost/server/v8 Go | From 11.5.0-rc1 | 11.5.0 |
github.com/mattermost/mattermost/server/v8 Go | From 11.5.0-rc1 | 11.5.0 |
6 more packages
github.com/mattermost/mattermost/server/v8 Go | From 8.0.0-20250721062209-4952acea88ce | 8.0.0-20260220133927-c29cf05d40f8 |
github.com/mattermost/mattermost/server/v8 Go | From 8.0.0-20250721062209-4952acea88ce | 8.0.0-20260220133927-c29cf05d40f8 |
github.com/mattermost/mattermost/server/v8 Go | From 8.0.0-20250721062209-4952acea88ce | 8.0.0-20260220133927-c29cf05d40f8 |
github.com/mattermost/mattermost-server Go | From 11.3.0-rc1+incompatible | 11.3.3+incompatible, 11.4.3+incompatible, 11.5.0+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
Products include Mattermost Mattermost Server.
How do I fix CVE-2026-28741?
Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 11.3.3, 11.4.3, 11.5.0 or 8.0.0-20260220133927-c29cf05d40f8.
Is CVE-2026-28741 being exploited?
There is no known exploitation of CVE-2026-28741 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-m7cf-4gh2-v4qg, GO-2026-5495.