# CVE-2026-28744: Gitea Git smart HTTP bypasses repository token scopes for bearer tokens

> Attackers can bypass repository token scope checks in Gitea Git smart HTTP requests using bearer tokens, potentially accessing unauthorized repositories.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jul 2026
- **Updated:** 6 Jul 2026
- **Also known as:** GHSA-cc8w-r4qh-3v65, GO-2026-5321

## What is CVE-2026-28744?

CVE-2026-28744 is a high-severity authentication bypass vulnerability in Gitea Open Source Git Server, published on 3 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Gitea versions up to and including 1.26.1 allow Git smart HTTP requests authenticated with bearer tokens to bypass repository token scope checks.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-28744?

3 open source packages ship an affected version, including code.gitea.io/gitea.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `code.gitea.io/gitea` | Go | All versions | 1.26.2 |
| `code.gitea.io/gitea` | Go | All versions | 1.26.2 |
| `code.gitea.io/gitea` | Go | All versions | 1.26.2 |

## How do I fix CVE-2026-28744?

Upgrade code.gitea.io/gitea to 1.26.2 or later.

## Is CVE-2026-28744 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-28744 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-28744 and fix it if it is affected.

What it is: CVE-2026-28744 is a high-severity authentication bypass vulnerability in Gitea Open Source Git Server, published on 3 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-28744 exists.

Affected packages and fixed versions:
- code.gitea.io/gitea (Go): affected all versions; fixed in 1.26.2
- code.gitea.io/gitea (Go): affected all versions; fixed in 1.26.2
- code.gitea.io/gitea (Go): affected all versions; fixed in 1.26.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-28744/ (Markdown: https://insights.sbomify.com/CVE-2026-28744/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-28744
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-28744
- OSV: https://osv.dev/vulnerability/CVE-2026-28744

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-28744/
Summaries are generated and may contain mistakes; the official description above is the record.
