CVE-2026-28759 Mattermost does not verify remote cluster channel access when processing shared channel membership removals

Medium 4.3 Published Updated

A malicious remote cluster can remove users from arbitrary channels, including private ones, due to insufficient authorization checks during membership synchronization.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-28759?

CVE-2026-28759 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 18 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Mattermost versions 11.5.x <= 11.5.1, 10.11.x <= 10.11.13, 11.4.x <= 11.4.3 fail to validate that a remote cluster has access to a channel before processing membership removal requests during shared channel membership sync, which allows a malicious remote cluster to remove any user from any channel, including private channels, via crafted membership sync messages targeting channels the remote cluster is not authorized to access. Mattermost Advisory ID: MMSA-2026-00576

Weakness: CWE-863

Which versions are affected by CVE-2026-28759?

14 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20260216150504-8738f8c4b3d4
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20260216150504-8738f8c4b3d4
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20260216150504-8738f8c4b3d4
github.com/mattermost/mattermost/server/v8 GoFrom 10.11.010.11.14
github.com/mattermost/mattermost/server/v8 GoFrom 10.11.010.11.14
github.com/mattermost/mattermost/server/v8 GoFrom 11.4.011.4.4
8 more packages
github.com/mattermost/mattermost/server/v8 GoFrom 11.4.011.4.4
github.com/mattermost/mattermost/server/v8 GoFrom 11.5.011.5.2
github.com/mattermost/mattermost/server/v8 GoFrom 11.5.011.5.2
github.com/mattermost/mattermost-server GoAll versions5.3.2-0.20260216150504-8738f8c4b3d4
github.com/mattermost/mattermost-server GoAll versions5.3.2-0.20260216150504-8738f8c4b3d4
github.com/mattermost/mattermost-server GoFrom 10.11.0+incompatible10.11.14+incompatible, 11.4.4+incompatible, 11.5.2+incompatible
github.com/mattermost/mattermost-server/v5 GoAll versionsNone
github.com/mattermost/mattermost-server/v6 GoAll versionsNone

Products include Mattermost Mattermost Server.

How do I fix CVE-2026-28759?

Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20260216150504-8738f8c4b3d4, 10.11.14, 11.4.4 or 11.5.2.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-28759 being exploited?

There is no known exploitation of CVE-2026-28759 in the wild and no public exploit code.

All Mattermost Mattermost Server vulnerabilities

Sources

Also known as GHSA-8h9w-w78c-vvr3, GO-2026-5256.

Is CVE-2026-28759 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free