# CVE-2026-28759: Mattermost does not verify remote cluster channel access when processing shared channel membership removals

> A malicious remote cluster can remove users from arbitrary channels, including private ones, due to insufficient authorization checks during membership synchronization.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 May 2026
- **Updated:** 18 May 2026
- **Also known as:** GHSA-8h9w-w78c-vvr3, GO-2026-5256

## What is CVE-2026-28759?

CVE-2026-28759 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 18 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mattermost versions 11.5.x <= 11.5.1, 10.11.x <= 10.11.13, 11.4.x <= 11.4.3 fail to validate that a remote cluster has access to a channel before processing membership removal requests during shared channel membership sync, which allows a malicious remote cluster to remove any user from any channel, including private channels, via crafted membership sync messages targeting channels the remote cluster is not authorized to access. Mattermost Advisory ID: MMSA-2026-00576

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-28759?

14 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20260216150504-8738f8c4b3d4 |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20260216150504-8738f8c4b3d4 |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20260216150504-8738f8c4b3d4 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 10.11.0 | 10.11.14 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 10.11.0 | 10.11.14 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 11.4.0 | 11.4.4 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 11.4.0 | 11.4.4 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 11.5.0 | 11.5.2 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 11.5.0 | 11.5.2 |
| `github.com/mattermost/mattermost-server` | Go | All versions | 5.3.2-0.20260216150504-8738f8c4b3d4 |
| `github.com/mattermost/mattermost-server` | Go | All versions | 5.3.2-0.20260216150504-8738f8c4b3d4 |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0+incompatible | 10.11.14+incompatible, 11.4.4+incompatible, 11.5.2+incompatible |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | None |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2026-28759?

Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20260216150504-8738f8c4b3d4, 10.11.14, 11.4.4 or 11.5.2.

## Is CVE-2026-28759 being exploited?

There is no known exploitation of CVE-2026-28759 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-28759 and fix it if it is affected.

What it is: CVE-2026-28759 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 18 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-28759 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20260216150504-8738f8c4b3d4
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20260216150504-8738f8c4b3d4
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20260216150504-8738f8c4b3d4
- github.com/mattermost/mattermost/server/v8 (Go): affected from 10.11.0; fixed in 10.11.14
- github.com/mattermost/mattermost/server/v8 (Go): affected from 10.11.0; fixed in 10.11.14
- github.com/mattermost/mattermost/server/v8 (Go): affected from 11.4.0; fixed in 11.4.4
- github.com/mattermost/mattermost/server/v8 (Go): affected from 11.4.0; fixed in 11.4.4
- github.com/mattermost/mattermost/server/v8 (Go): affected from 11.5.0; fixed in 11.5.2
- github.com/mattermost/mattermost/server/v8 (Go): affected from 11.5.0; fixed in 11.5.2
- github.com/mattermost/mattermost-server (Go): affected all versions; fixed in 5.3.2-0.20260216150504-8738f8c4b3d4
- github.com/mattermost/mattermost-server (Go): affected all versions; fixed in 5.3.2-0.20260216150504-8738f8c4b3d4
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0+incompatible; fixed in 10.11.14+incompatible, 11.4.4+incompatible, 11.5.2+incompatible

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-28759/ (Markdown: https://insights.sbomify.com/CVE-2026-28759/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-28759
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-28759
- OSV: https://osv.dev/vulnerability/CVE-2026-28759

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-28759/
Summaries are generated and may contain mistakes; the official description above is the record.
