CVE-2026-28780 Apache HTTP Server: buffer overflow in mod_proxy_ajp via ajp_msg_check_header()

Critical 9.8 Published Updated

A heap-based buffer overflow in Apache HTTP Server's mod_proxy_ajp allows attackers to execute code or cause denial of service via malicious AJP responses.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-28780?

CVE-2026-28780 is a critical memory corruption vulnerability in Apache Http Server, published on 5 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Heap-based Buffer Overflow vulnerability in mod_proxy_ajp of Apache HTTP Server. If mod_proxy_ajp connects to a malicious AJP server this AJP server can send a malicious AJP message back to mod_proxy_ajp and cause it to write 4 attacker controlled bytes after the end of a heap based buffer.

This issue affects Apache HTTP Server: through 2.4.66.

Users are recommended to upgrade to version 2.4.67, which fixes the issue.

Weakness: CWE-787, CWE-122

Which versions are affected by CVE-2026-28780?

1 open source package ship an affected version, including apache. It affects 1 product.

PackageAffectedFixed in
apache BitnamiAll versions2.4.67

Products include Apache Http Server.

How do I fix CVE-2026-28780?

Upgrade apache to 2.4.67 or later.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2026-28780 being exploited?

There is no known exploitation of CVE-2026-28780 in the wild and no public exploit code.

All Apache Http Server vulnerabilities

Sources

Also known as ALPINE-CVE-2026-28780, BELL-CVE-2026-28780, BIT-apache-2026-28780, CLSA-2026-1778847162, CLSA-2026-1779124722, CLSA-2026-1779129626 and 5 more.

Is CVE-2026-28780 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free