{"answers":{"affected":"1 open source package ship an affected version, including apache. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-28780 in the wild and no public exploit code.","fix":"Upgrade apache to 2.4.67 or later.","what":"CVE-2026-28780 is a critical memory corruption vulnerability in Apache Http Server, published on 5 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-28780 and fix it if it is affected.\n\nWhat it is: CVE-2026-28780 is a critical memory corruption vulnerability in Apache Http Server, published on 5 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-28780 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache (Bitnami): affected all versions; fixed in 2.4.67\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-28780/ (Markdown: https://insights.sbomify.com/CVE-2026-28780/index.md)","id":"CVE-2026-28780","markdown":"https://insights.sbomify.com/CVE-2026-28780/index.md","name":"CVE-2026-28780","record":{"aliases":["ALPINE-CVE-2026-28780","BELL-CVE-2026-28780","BIT-apache-2026-28780","CLSA-2026-1778847162","CLSA-2026-1779124722","CLSA-2026-1779129626","CLSA-2026-1779129849","DEBIAN-CVE-2026-28780","GHSA-wpww-4qvv-xpv8","MINI-m3q3-wg26-75jc","OESA-2026-2317"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache HTTP Server","requires_auth":"none","summary":"A heap-based buffer overflow in Apache HTTP Server's mod_proxy_ajp allows attackers to execute code or cause denial of service via malicious AJP responses.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"http_server","vendor":"apache"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"},{"id":"CWE-122","name":"Heap-based Buffer Overflow"}],"description":"Heap-based Buffer Overflow vulnerability in mod_proxy_ajp of Apache HTTP Server.\nIf mod_proxy_ajp connects to a malicious AJP server this AJP server can send a malicious AJP message back to mod_proxy_ajp and cause it to write 4 attacker controlled bytes after the end of a heap based buffer.\n\nThis issue affects Apache HTTP Server: through 2.4.66.\n\nUsers are recommended to upgrade to version 2.4.67, which fixes the issue.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache HTTP Server: buffer overflow in mod_proxy_ajp via ajp_msg_check_header()","id":"CVE-2026-28780","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"apache:http_server","products":["apache:http_server"],"type":"memory_corruption","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"Craft Affected by Entries Authorship Spoofing via Mass Assignment","id":"CVE-2026-28781"},"packages":[{"ecosystem":"Bitnami","fixed":["2.4.67"],"introduced":["0"],"last_affected":[],"package":"apache","purl":"pkg:bitnami/apache","source":"BIT-apache-2026-28780"}],"prev":{"headline":"Apache Airflow: Path of session token in cookie does not consider base_url - session hijacking via co-hosted applications","id":"CVE-2026-28779"},"products":["Apache HTTP Server"],"published":"2026-05-05","related":[{"cvss_score":9.8,"headline":"Apache HTTP Server Path Traversal","id":"CVE-2021-42013","kev_date_added":"2021-11-03","published":"2021-10-07"},{"cvss_score":9.1,"headline":"Apache HTTP Server Improper Escaping of Output","id":"CVE-2024-38475","kev_date_added":"2025-05-01","published":"2024-07-01"},{"cvss_score":9,"headline":"Apache HTTP Server-Side Request Forgery (SSRF)","id":"CVE-2021-40438","kev_date_added":"2021-12-01","published":"2021-09-16"},{"cvss_score":7.8,"headline":"Apache HTTP Server Privilege Escalation","id":"CVE-2019-0211","kev_date_added":"2021-11-03","published":"2019-04-08"},{"cvss_score":7.5,"headline":"Apache HTTP Server Path Traversal","id":"CVE-2021-41773","kev_date_added":"2021-11-03","published":"2021-10-05"},{"cvss_score":10,"headline":"Use after free in n/a","id":"CVE-2010-0425","kev_date_added":null,"published":"2010-03-05"},{"cvss_score":10,"headline":"Auth bypass in n/a","id":"CVE-2005-2700","kev_date_added":null,"published":"2005-09-06"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-14","vendors":["Apache Software Foundation"]},"summary":"A heap-based buffer overflow in Apache HTTP Server's mod_proxy_ajp allows attackers to execute code or cause denial of service via malicious AJP responses.","url":"https://insights.sbomify.com/CVE-2026-28780/"}