# CVE-2026-28780: Apache HTTP Server: buffer overflow in mod_proxy_ajp via ajp_msg_check_header()

> A heap-based buffer overflow in Apache HTTP Server's mod_proxy_ajp allows attackers to execute code or cause denial of service via malicious AJP responses.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 May 2026
- **Updated:** 14 Sep 2026
- **Also known as:** ALPINE-CVE-2026-28780, BELL-CVE-2026-28780, BIT-apache-2026-28780, CLSA-2026-1778847162, CLSA-2026-1779124722, CLSA-2026-1779129626, CLSA-2026-1779129849, DEBIAN-CVE-2026-28780, GHSA-wpww-4qvv-xpv8, MINI-m3q3-wg26-75jc, OESA-2026-2317

## What is CVE-2026-28780?

CVE-2026-28780 is a critical memory corruption vulnerability in Apache Http Server, published on 5 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Heap-based Buffer Overflow vulnerability in mod_proxy_ajp of Apache HTTP Server.
If mod_proxy_ajp connects to a malicious AJP server this AJP server can send a malicious AJP message back to mod_proxy_ajp and cause it to write 4 attacker controlled bytes after the end of a heap based buffer.

This issue affects Apache HTTP Server: through 2.4.66.

Users are recommended to upgrade to version 2.4.67, which fixes the issue.

Weakness: CWE-787 (Out-of-bounds Write), CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2026-28780?

1 open source package ship an affected version, including apache. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache` | Bitnami | All versions | 2.4.67 |

Products: Apache Http Server.

## How do I fix CVE-2026-28780?

Upgrade apache to 2.4.67 or later.

## Is CVE-2026-28780 being exploited?

There is no known exploitation of CVE-2026-28780 in the wild and no public exploit code.

## Other vulnerabilities in Apache Http Server

- [CVE-2021-42013](https://insights.sbomify.com/CVE-2021-42013/): Apache HTTP Server Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2024-38475](https://insights.sbomify.com/CVE-2024-38475/): Apache HTTP Server Improper Escaping of Output (critical 9.1, exploited in the wild)
- [CVE-2021-40438](https://insights.sbomify.com/CVE-2021-40438/): Apache HTTP Server-Side Request Forgery (SSRF) (critical 9.0, exploited in the wild)
- [CVE-2019-0211](https://insights.sbomify.com/CVE-2019-0211/): Apache HTTP Server Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2021-41773](https://insights.sbomify.com/CVE-2021-41773/): Apache HTTP Server Path Traversal (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-28780 and fix it if it is affected.

What it is: CVE-2026-28780 is a critical memory corruption vulnerability in Apache Http Server, published on 5 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-28780 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache (Bitnami): affected all versions; fixed in 2.4.67

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-28780/ (Markdown: https://insights.sbomify.com/CVE-2026-28780/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-28780
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-28780
- OSV: https://osv.dev/vulnerability/CVE-2026-28780

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-28780/
Summaries are generated and may contain mistakes; the official description above is the record.
