# CVE-2026-28782: Craft has a Permission Bypass and IDOR in Duplicate Entry Action

> Attackers can bypass permissions to duplicate other users' entries via IDOR, leading to unauthorized data access and modification in Craft CMS.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Mar 2026
- **Updated:** 4 Mar 2026
- **Also known as:** GHSA-jxm3-pmm2-9gf6

## What is CVE-2026-28782?

CVE-2026-28782 is a medium-severity missing authorization vulnerability in Craftcms Craft Cms, published on 4 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Craft is a content management system (CMS). Prior to 5.9.0-beta.1 and 4.17.0-beta.1, the "Duplicate" entry action does not properly verify if the user has permission to perform this action on the specific target elements. Even with only "View Entries" permission (where the "Duplicate" action is restricted in the UI), a user can bypass this restriction by sending a direct request. Furthermore, this vulnerability allows duplicating other users' entries by specifying their Entry IDs. Since Entry IDs are incremental, an attacker can trivially brute-force these IDs to duplicate and access restricted content across the system. This vulnerability is fixed in 5.9.0-beta.1 and 4.17.0-beta.1.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-28782?

4 open source packages ship an affected version, including craftcms/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/cms` | Packagist | From 4.0.0-RC1 | 4.17.0-beta.1 |
| `craftcms/cms` | Packagist | From 4.0.0-RC1 | 4.17.0-beta.1 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.9.0-beta.1 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.9.0-beta.1 |

Products: Craftcms Craft Cms.

## How do I fix CVE-2026-28782?

Upgrade craftcms/cms to a fixed version for your release line: 4.17.0-beta.1 or 5.9.0-beta.1.

## Is CVE-2026-28782 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-28782 exists.

## Other vulnerabilities in Craftcms Craft Cms

- [CVE-2025-32432](https://insights.sbomify.com/CVE-2025-32432/): Craft CMS Code Injection (critical 10.0, exploited in the wild)
- [CVE-2024-56145](https://insights.sbomify.com/CVE-2024-56145/): Craft CMS Code Injection (critical 9.3, exploited in the wild)
- [CVE-2025-23209](https://insights.sbomify.com/CVE-2025-23209/): Craft CMS Code Injection (high 8.1, exploited in the wild)
- [CVE-2025-35939](https://insights.sbomify.com/CVE-2025-35939/): Craft CMS External Control of Assumed-Immutable Web Parameter (medium 6.9, exploited in the wild)
- [CVE-2023-41892](https://insights.sbomify.com/CVE-2023-41892/): Craft CMS Remote Code Execution vulnerability (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-28782 and fix it if it is affected.

What it is: CVE-2026-28782 is a medium-severity missing authorization vulnerability in Craftcms Craft Cms, published on 4 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-28782 exists.

Affected packages and fixed versions:
- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.17.0-beta.1
- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.17.0-beta.1
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.9.0-beta.1
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.9.0-beta.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-28782/ (Markdown: https://insights.sbomify.com/CVE-2026-28782/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-28782
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-28782
- OSV: https://osv.dev/vulnerability/CVE-2026-28782

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-28782/
Summaries are generated and may contain mistakes; the official description above is the record.
