CVE-2026-28784 Craft is affected by potential authenticated Remote Code Execution via Twig SSTI
Authenticated attackers can achieve remote code execution via Twig SSTI in Craft CMS if admin changes are allowed or specific utilities are accessible.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-28784?
CVE-2026-28784 is a high-severity code injection vulnerability in Craftcms Craft Cms, published on 4 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Craft is a content management system (CMS). Prior to 5.8.22 and 4.16.18, it is possible to craft a malicious payload using the Twig map filter in text fields that accept Twig input under Settings in the Craft control panel or using the System Messages utility, which could lead to a RCE. For this to work, you must have administrator access to the Craft Control Panel, and allowAdminChanges must be enabled for this to work, which is against our recommendations for any non-dev environment. Alternatively, you can have a non-administrator account with allowAdminChanges disabled, but you have access to the System Messages utility. Users should update to the patched versions (5.8.22 and 4.16.18) to mitigate the issue.
Weakness: CWE-1336
Which versions are affected by CVE-2026-28784?
4 open source packages ship an affected version, including craftcms/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
craftcms/cms Packagist | From 4.0.0-RC1 | 4.17.0-beta.1 |
craftcms/cms Packagist | From 4.0.0-RC1 | 4.17.0-beta.1 |
craftcms/cms Packagist | From 5.0.0-RC1 | 5.9.0-beta.1 |
craftcms/cms Packagist | From 5.0.0-RC1 | 5.9.0-beta.1 |
Products include Craftcms Craft Cms.
How do I fix CVE-2026-28784?
Upgrade craftcms/cms to a fixed version for your release line: 4.17.0-beta.1 or 5.9.0-beta.1.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-28784 being exploited?
There is no known exploitation of CVE-2026-28784 in the wild and no public exploit code.
Other vulnerabilities in Craftcms Craft Cms
Sources
Also known as GHSA-qc86-q28f-ggww.