# CVE-2026-28784: Craft is affected by potential authenticated Remote Code Execution via Twig SSTI

> Authenticated attackers can achieve remote code execution via Twig SSTI in Craft CMS if admin changes are allowed or specific utilities are accessible.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Mar 2026
- **Updated:** 6 Mar 2026
- **Also known as:** GHSA-qc86-q28f-ggww

## What is CVE-2026-28784?

CVE-2026-28784 is a high-severity code injection vulnerability in Craftcms Craft Cms, published on 4 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Craft is a content management system (CMS). Prior to 5.8.22 and 4.16.18, it is possible to craft a malicious payload using the Twig map filter in text fields that accept Twig input under Settings in the Craft control panel or using the System Messages utility, which could lead to a RCE. For this to work, you must have administrator access to the Craft Control Panel, and allowAdminChanges must be enabled for this to work, which is against our recommendations for any non-dev environment. Alternatively, you can have a non-administrator account with allowAdminChanges disabled, but you have access to the System Messages utility. Users should update to the patched versions (5.8.22 and 4.16.18) to mitigate the issue.

Weakness: CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2026-28784?

4 open source packages ship an affected version, including craftcms/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/cms` | Packagist | From 4.0.0-RC1 | 4.17.0-beta.1 |
| `craftcms/cms` | Packagist | From 4.0.0-RC1 | 4.17.0-beta.1 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.9.0-beta.1 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.9.0-beta.1 |

Products: Craftcms Craft Cms.

## How do I fix CVE-2026-28784?

Upgrade craftcms/cms to a fixed version for your release line: 4.17.0-beta.1 or 5.9.0-beta.1.

## Is CVE-2026-28784 being exploited?

There is no known exploitation of CVE-2026-28784 in the wild and no public exploit code.

## Other vulnerabilities in Craftcms Craft Cms

- [CVE-2025-32432](https://insights.sbomify.com/CVE-2025-32432/): Craft CMS Code Injection (critical 10.0, exploited in the wild)
- [CVE-2024-56145](https://insights.sbomify.com/CVE-2024-56145/): Craft CMS Code Injection (critical 9.3, exploited in the wild)
- [CVE-2025-23209](https://insights.sbomify.com/CVE-2025-23209/): Craft CMS Code Injection (high 8.1, exploited in the wild)
- [CVE-2025-35939](https://insights.sbomify.com/CVE-2025-35939/): Craft CMS External Control of Assumed-Immutable Web Parameter (medium 6.9, exploited in the wild)
- [CVE-2023-41892](https://insights.sbomify.com/CVE-2023-41892/): Craft CMS Remote Code Execution vulnerability (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-28784 and fix it if it is affected.

What it is: CVE-2026-28784 is a high-severity code injection vulnerability in Craftcms Craft Cms, published on 4 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-28784 in the wild and no public exploit code.

Affected packages and fixed versions:
- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.17.0-beta.1
- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.17.0-beta.1
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.9.0-beta.1
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.9.0-beta.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-28784/ (Markdown: https://insights.sbomify.com/CVE-2026-28784/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-28784
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-28784
- OSV: https://osv.dev/vulnerability/CVE-2026-28784

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-28784/
Summaries are generated and may contain mistakes; the official description above is the record.
