# CVE-2026-28788: Open WebUI's process_files_batch() endpoint missing ownership check, allows unauthorized file overwrite

> Authenticated users can overwrite shared knowledge base files due to missing ownership checks, allowing control over LLM responses for other users.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Mar 2026
- **Updated:** 27 Mar 2026
- **Also known as:** GHSA-jjp7-g2jw-wh3j, PYSEC-2026-2742

## What is CVE-2026-28788?

CVE-2026-28788 is a high-severity missing authorization vulnerability in Openwebui Open Webui, published on 26 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Open WebUI is a self-hosted artificial intelligence platform designed to operate entirely offline. Prior to version 0.8.6, any authenticated user can overwrite any file's content by ID through the `POST /api/v1/retrieval/process/files/batch` endpoint. The endpoint performs no ownership check, so a regular user with read access to a shared knowledge base can obtain file UUIDs via `GET /api/v1/knowledge/{id}/files` and then overwrite those files, escalating from read to write. The overwritten content is served to the LLM via RAG, meaning the attacker controls what the model tells other users. Version 0.8.6 patches the issue.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-28788?

3 open source packages ship an affected version, including open-webui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `open-webui` | PyPI | All versions | 0.8.6 |
| `open-webui` | PyPI | All versions | 0.8.6 |
| `open-webui` | PyPI | All versions | 0.8.6 |

Products: Openwebui Open Webui.

## How do I fix CVE-2026-28788?

Upgrade open-webui to 0.8.6 or later.

## Is CVE-2026-28788 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-28788 exists.

## Other vulnerabilities in Openwebui Open Webui

- [CVE-2026-44551](https://insights.sbomify.com/CVE-2026-44551/): Open WebUI: LDAP Empty Password Authentication Bypass (critical 9.1)
- [CVE-2026-56400](https://insights.sbomify.com/CVE-2026-56400/): open-webui - Remote Code Execution via CORS Misconfiguration and Session Validation (critical 9.0)
- [CVE-2024-8017](https://insights.sbomify.com/CVE-2024-8017/): Cross-site Scripting (XSS) in open-webui/open-webui (critical 9.0)
- [CVE-2026-45672](https://insights.sbomify.com/CVE-2026-45672/): Open WebUI: Jupyter code execution works despite `ENABLE_CODE_EXECUTION=false` — feature gate bypassed (high 8.8)
- [CVE-2026-87995](https://insights.sbomify.com/CVE-2026-87995/): Open WebUI: Same-origin XSS to account takeover via terminal port-preview iframe hardcoding allow-same-origin (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-28788 and fix it if it is affected.

What it is: CVE-2026-28788 is a high-severity missing authorization vulnerability in Openwebui Open Webui, published on 26 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-28788 exists.

Affected packages and fixed versions:
- open-webui (PyPI): affected all versions; fixed in 0.8.6
- open-webui (PyPI): affected all versions; fixed in 0.8.6
- open-webui (PyPI): affected all versions; fixed in 0.8.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-28788/ (Markdown: https://insights.sbomify.com/CVE-2026-28788/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-28788
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-28788
- OSV: https://osv.dev/vulnerability/CVE-2026-28788

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-28788/
Summaries are generated and may contain mistakes; the official description above is the record.
