# CVE-2026-28795: OpenChatBI: Critical Path Traversal Vulnerability in save_report Tool of OpenChatBI

> Attackers can exploit insufficient input sanitization in the save_report tool to read or modify arbitrary files on the server.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Mar 2026
- **Updated:** 9 Mar 2026
- **Also known as:** GHSA-vmwq-8g8c-jm79, PYSEC-2026-2794

## What is CVE-2026-28795?

CVE-2026-28795 is a high-severity path traversal vulnerability in zhongyu09 openchatbi, published on 6 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenChatBI is an intelligent chat-based BI tool powered by large language models, designed to help users query, analyze, and visualize data through natural language conversations. Prior to version 0.2.2, the save_report tool in openchatbi/tool/save_report.py suffers from a critical path traversal vulnerability due to insufficient input sanitization of the file_format parameter. This issue has been patched in version 0.2.2.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-28795?

3 open source packages ship an affected version, including openchatbi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openchatbi` | PyPI | All versions | 0.2.2 |
| `openchatbi` | PyPI | All versions | 0.2.2 |
| `openchatbi` | PyPI | All versions | 0.2.2 |

Products: Zhongyu09 Openchatbi.

## How do I fix CVE-2026-28795?

Upgrade openchatbi to 0.2.2 or later.

## Is CVE-2026-28795 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-28795 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-28795 and fix it if it is affected.

What it is: CVE-2026-28795 is a high-severity path traversal vulnerability in zhongyu09 openchatbi, published on 6 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-28795 exists.

Affected packages and fixed versions:
- openchatbi (PyPI): affected all versions; fixed in 0.2.2
- openchatbi (PyPI): affected all versions; fixed in 0.2.2
- openchatbi (PyPI): affected all versions; fixed in 0.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-28795/ (Markdown: https://insights.sbomify.com/CVE-2026-28795/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-28795
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-28795
- OSV: https://osv.dev/vulnerability/CVE-2026-28795

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-28795/
Summaries are generated and may contain mistakes; the official description above is the record.
