# CVE-2026-2880: @fastify/middie has an improper path normalization vulnerability

> Attackers can bypass path-scoped authentication middleware in @fastify/middie by exploiting path normalization inconsistencies when specific router options are enabled.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Feb 2026
- **Updated:** 27 Feb 2026
- **Also known as:** GHSA-8p85-9qpw-fwgw

## What is CVE-2026-2880?

CVE-2026-2880 is a high-severity authentication bypass vulnerability in @fastify/middie, published on 27 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability in @fastify/middie versions < 9.2.0 can result in authentication/authorization bypass when using path-scoped middleware (for example, app.use('/secret', auth)).

When Fastify router normalization options are enabled (such as ignoreDuplicateSlashes, useSemicolonDelimiter, and related trailing-slash behavior), crafted request paths may bypass middleware checks while still being routed to protected handlers.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-2880?

2 open source packages ship an affected version, including @fastify/middie. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@fastify/middie` | npm | All versions | 9.2.0 |
| `@fastify/middie` | npm | All versions | 9.2.0 |

Products: Fastify Fastify\/Middie.

## How do I fix CVE-2026-2880?

Upgrade @fastify/middie to 9.2.0 or later.

## Is CVE-2026-2880 being exploited?

There is no known exploitation of CVE-2026-2880 in the wild and no public exploit code.

## Other vulnerabilities in @fastify/middie

- [CVE-2026-85184](https://insights.sbomify.com/CVE-2026-85184/): @fastify/middie vulnerable to path-scoped middleware bypass via absolute-form request target (critical 9.1)
- [CVE-2026-14198](https://insights.sbomify.com/CVE-2026-14198/): @fastify/middie vulnerable to authorization bypass via encoded slash in path parameter values (critical 9.1)
- [CVE-2026-6270](https://insights.sbomify.com/CVE-2026-6270/): @fastify/middie vulnerable to middleware authentication bypass in child plugin scopes (critical 9.1)
- [CVE-2026-22031](https://insights.sbomify.com/CVE-2026-22031/): Fastify Middie Middleware Path Bypass (high 8.4)
- [CVE-2026-14181](https://insights.sbomify.com/CVE-2026-14181/): @fastify/middie standalone engine vulnerable to Denial of Service via malformed percent-encoded paths (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-2880 and fix it if it is affected.

What it is: CVE-2026-2880 is a high-severity authentication bypass vulnerability in @fastify/middie, published on 27 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-2880 in the wild and no public exploit code.

Affected packages and fixed versions:
- @fastify/middie (npm): affected all versions; fixed in 9.2.0
- @fastify/middie (npm): affected all versions; fixed in 9.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-2880/ (Markdown: https://insights.sbomify.com/CVE-2026-2880/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-2880
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-2880
- OSV: https://osv.dev/vulnerability/CVE-2026-2880

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-2880/
Summaries are generated and may contain mistakes; the official description above is the record.
