# CVE-2026-28807: Path Traversal in wisp.serve_static allows arbitrary file read

> An unauthenticated attacker can read arbitrary files via percent-encoded path traversal in the wisp.serve_static function.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Mar 2026
- **Updated:** 6 Apr 2026
- **Also known as:** EEF-CVE-2026-28807, GHSA-h7cj-j2vv-qw8r

## What is CVE-2026-28807?

CVE-2026-28807 is a high-severity path traversal vulnerability in gleam-wisp wisp, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in gleam-wisp wisp allows arbitrary file read via percent-encoded path traversal.

The wisp.serve_static function is vulnerable to path traversal because sanitization runs before percent-decoding. The encoded sequence %2e%2e passes through string.replace unchanged, then uri.percent_decode converts it to .., which the OS resolves as directory traversal when the file is read.

An unauthenticated attacker can read any file readable by the application process in a single HTTP request, including application source code, configuration files, secrets, and system files.

This issue affects wisp: from 2.1.1 before 2.2.1.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-28807?

3 open source packages ship an affected version, including wisp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wisp` | Hex | From 2.1.1 | 2.2.1 |
| `wisp` | Hex | From 2.1.1 | 2.2.1 |
| `wisp` | Hex | From 2.1.1 | 2.2.1 |

Products: Gleam-Wisp Wisp.

## How do I fix CVE-2026-28807?

Upgrade wisp to 2.2.1 or later.

## Is CVE-2026-28807 being exploited?

There is no known exploitation of CVE-2026-28807 in the wild and no public exploit code.

## Other vulnerabilities in gleam-wisp wisp

- [CVE-2026-32145](https://insights.sbomify.com/CVE-2026-32145/): Multipart form body parser bypasses body size limits in wisp (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-28807 and fix it if it is affected.

What it is: CVE-2026-28807 is a high-severity path traversal vulnerability in gleam-wisp wisp, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-28807 in the wild and no public exploit code.

Affected packages and fixed versions:
- wisp (Hex): affected from 2.1.1; fixed in 2.2.1
- wisp (Hex): affected from 2.1.1; fixed in 2.2.1
- wisp (Hex): affected from 2.1.1; fixed in 2.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-28807/ (Markdown: https://insights.sbomify.com/CVE-2026-28807/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-28807
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-28807
- OSV: https://osv.dev/vulnerability/CVE-2026-28807

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-28807/
Summaries are generated and may contain mistakes; the official description above is the record.
