CVE-2026-28811 Apache JSPWiki: Error Handling - Reveals Error Details

High 7.5 Published Updated

Apache JSPWiki exposes unnecessary debug information in error messages, potentially revealing sensitive details to attackers.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-28811?

CVE-2026-28811 is a high-severity vulnerability in Apache JSPWiki, published on 30 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Debug Messages Revealing Unnecessary Information in Apache JSPWiki up to 2.12.3. Users are recommended to upgrade to version 2.12.4, which fixes this issue.

Weakness: CWE-1295

Which versions are affected by CVE-2026-28811?

It affects 1 product.

Products include Apache Jspwiki.

How do I fix CVE-2026-28811?

No fix has been published for CVE-2026-28811 yet. Limit exposure of the affected software until one is available.

Is CVE-2026-28811 being exploited?

There is no known exploitation of CVE-2026-28811 in the wild and no public exploit code.

Sources

Also known as GHSA-4xg4-cv39-wq7w.

Is CVE-2026-28811 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free